summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-06-17 23:17:33 +0100
committerMarek Szuba <marecki@gentoo.org>2023-06-17 23:18:22 +0100
commit5d622214c2a1d6424ab1f4f5d3f7dbe22f881aa8 (patch)
treef91888837297e8ba7c39a00415ba4017d67565ef /dev-python/python-rtmidi
parentapp-backup/snapper: add 0.10.5 (diff)
downloadgentoo-5d622214c2a1d6424ab1f4f5d3f7dbe22f881aa8.tar.gz
gentoo-5d622214c2a1d6424ab1f4f5d3f7dbe22f881aa8.tar.bz2
gentoo-5d622214c2a1d6424ab1f4f5d3f7dbe22f881aa8.zip
dev-python/python-rtmidi: add 1.5.2, drop 1.5.1
Closes: https://bugs.gentoo.org/908657 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-python/python-rtmidi')
-rw-r--r--dev-python/python-rtmidi/Manifest2
-rw-r--r--dev-python/python-rtmidi/files/python-rtmidi-1.5.2-build_backend.patch (renamed from dev-python/python-rtmidi/files/python-rtmidi-1.5.1-build_backend.patch)13
-rw-r--r--dev-python/python-rtmidi/python-rtmidi-1.5.2.ebuild (renamed from dev-python/python-rtmidi/python-rtmidi-1.5.1.ebuild)16
3 files changed, 20 insertions, 11 deletions
diff --git a/dev-python/python-rtmidi/Manifest b/dev-python/python-rtmidi/Manifest
index e26c6e5a7dcb..091c77559be5 100644
--- a/dev-python/python-rtmidi/Manifest
+++ b/dev-python/python-rtmidi/Manifest
@@ -1,2 +1,2 @@
DIST python-rtmidi-1.4.9.tar.gz 251238 BLAKE2B dda4052e893839f88a6756306f8ff4e89ee66ad9716d374efbb7b92a8e9074e98c8d5df0cc82aa3c6e0c77a78fe9b997079623a5147c03eeea9128dfb7605215 SHA512 91c5a0f807549fbe9d87df6e40b8c3db0f9be753616ba51804900195d02120cd972e39c69dd99e60e4ea1b1d9831d0b956b64ce71b2fe03422efc57bccf5cb70
-DIST python-rtmidi-1.5.1.tar.gz 331487 BLAKE2B fafa56132c54c20a702bcdc7dbe87b9eb3384ecf1e53ee76926866ba6f6fb601f55f4525f6b12f477f8659e4da8138940c5037ac0a4f31f472261089f0d25b03 SHA512 656690f397983834a719be6b58db66db066469b356ef00ff8d62666af9b5e3ef572e541cf38e082b2122a31d8895fd52c0392ed6bdec387baf3f5827de411254
+DIST python-rtmidi-1.5.2.tar.gz 332527 BLAKE2B 8779ea9952c4aeb5673ab26b04899ecb6582d29b9da081f726ce3f41ed0b96cc25239cebb69ebb847efc700332c3d47bf00f1eec6a0d092e0244e1cabe84f0b9 SHA512 025b356a2e0aefab53cf84e8d3cb6396058175e01cf2176336121babb4548b767b29bcd2e678fc2389c30df81586ee9395f51ab8acbde82f7f7f589935d65f4c
diff --git a/dev-python/python-rtmidi/files/python-rtmidi-1.5.1-build_backend.patch b/dev-python/python-rtmidi/files/python-rtmidi-1.5.2-build_backend.patch
index fdb2a14b7c7d..511e86f836df 100644
--- a/dev-python/python-rtmidi/files/python-rtmidi-1.5.1-build_backend.patch
+++ b/dev-python/python-rtmidi/files/python-rtmidi-1.5.2-build_backend.patch
@@ -18,16 +18,19 @@
description = "A Python binding for the RtMidi C++ library implemented using Cython."
authors = [
{ name="Christopher Arndt", email="info@chrisarndt.de" },
-@@ -41,12 +41,6 @@
+@@ -41,11 +41,12 @@
"music",
"rtmidi",
]
-meson-python-option-name = "python"
-meson-options = [
-- "-Dwheel=true",
-- "-Dverbose=true",
++
++[tool.meson-python.args]
++setup = [
+ "-Dwheel=true",
+ "-Dverbose=false",
- "--buildtype=plain"
--]
++ "-Dbuildtype=plain"
+ ]
[project.license]
- file = "LICENSE.md"
diff --git a/dev-python/python-rtmidi/python-rtmidi-1.5.1.ebuild b/dev-python/python-rtmidi/python-rtmidi-1.5.2.ebuild
index abefc8615ade..4185174c3c76 100644
--- a/dev-python/python-rtmidi/python-rtmidi-1.5.1.ebuild
+++ b/dev-python/python-rtmidi/python-rtmidi-1.5.2.ebuild
@@ -3,12 +3,15 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+DOCS_BUILDER="sphinx"
+DOCS_DEPEND="dev-python/myst-parser"
+DOCS_DIR="docs"
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=meson-python
PYPI_NO_NORMALIZE=1
-inherit distutils-r1 pypi
+inherit distutils-r1 docs pypi
DESCRIPTION="Python bindings for media-libs/rtmidi implemented using Cython"
HOMEPAGE="
@@ -33,12 +36,11 @@ BDEPEND="<dev-python/cython-2.99[${PYTHON_USEDEP}]
virtual/pkgconfig"
PATCHES=(
- "${FILESDIR}"/${PN}-1.5.1-build_backend.patch
"${FILESDIR}"/${PN}-1.5.1-meson_pure.patch
"${FILESDIR}"/${PN}-1.5.1-unbundle_rtmidi.patch
+ "${FILESDIR}"/${PN}-1.5.2-build_backend.patch
)
-distutils_enable_sphinx docs
distutils_enable_tests unittest
src_prepare() {
@@ -48,7 +50,11 @@ src_prepare() {
rm -r src/rtmidi || die
rm src/_rtmidi.cpp || die
- DISTUTILS_ARGS=( -Dwheel=true )
+ # Needed by USE=doc because documentation generation happens in ${S}
+ # but the version.py generated by Meson end up in respective ${BUILD_DIR}s.
+ # The version put in ${S} should be ignored by everything except Sphinx but
+ # just in case, be consistent and generate it unconditionally.
+ sed -e "s|@VERSION@|${PV}|" < rtmidi/version.py.in > rtmidi/version.py || die
}
python_test() {