summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-21 21:03:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-21 21:12:59 +0200
commit6ba63411bb3154d52e51f6e377a1bf961bcf2198 (patch)
treed26142e443f5c29d09fa4caa0f120e56ca752dc5 /dev-python/python-socks
parentdev-python/recurring-ical-events: Bump to 3.1.1 (diff)
downloadgentoo-6ba63411bb3154d52e51f6e377a1bf961bcf2198.tar.gz
gentoo-6ba63411bb3154d52e51f6e377a1bf961bcf2198.tar.bz2
gentoo-6ba63411bb3154d52e51f6e377a1bf961bcf2198.zip
dev-python/python-socks: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.5.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 815fc5a9be22..6a53d16f6460 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-2.5.0.gh.tar.gz 32293 BLAKE2B 20eaa8b27d695116f9d03bfa1807496c789a43804c06f441f7961d928095d169f9b581120c29d188e0eda39d15b517012647e6f6f682a29c260179dca422b0dc SHA512 d59a3eb851c80556e08513ae417a109da6670b81858df365818ca187d14b57719ee86c6a65d9e8a8366ad3c7a2516a10cabcbf9895d8456b5f188c80dae74eee
+DIST python-socks-2.5.1.gh.tar.gz 32387 BLAKE2B a0f488a146b09433bee39382ace3143a31a55d3fccd2db5e5ca6c2a08f3e17abee5839a266f8dc1b1b3ac6add7584cfba988aacba575ed5d21a464f8a2f1464f SHA512 6f2491272d201abc06a0d0a4fae242899ed28f9caeb7bea42c33946daec3280b48a956319b82a89ebeb8ea61ab9c290f9360d6ea85eb4d654525b95faa3ffce0
diff --git a/dev-python/python-socks/python-socks-2.5.1.ebuild b/dev-python/python-socks/python-socks-2.5.1.ebuild
new file mode 100644
index 000000000000..4bfe898288dd
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.5.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest