summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-26 03:52:25 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-26 04:09:37 +0200
commite9fd9cb8a497060775eea85eb393b9d6179140e2 (patch)
treea3b93bb8ba3df339c5761d84cb956d7f2c6ecf9f /dev-python/python-socks
parentdev-python/reportlab: Bump to 4.2.2 (diff)
downloadgentoo-e9fd9cb8a497060775eea85eb393b9d6179140e2.tar.gz
gentoo-e9fd9cb8a497060775eea85eb393b9d6179140e2.tar.bz2
gentoo-e9fd9cb8a497060775eea85eb393b9d6179140e2.zip
dev-python/python-socks: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/python-socks-2.5.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
index 786c6eabf23a..0c01fb45aade 100644
--- a/dev-python/python-socks/Manifest
+++ b/dev-python/python-socks/Manifest
@@ -1 +1,2 @@
DIST python-socks-2.4.4.gh.tar.gz 31998 BLAKE2B c3aa137ff679790420ded9644987eed23695c82a5621c420350ad52ca8121215326575f4c389912fb646151fc84187bfab38674ff6dc2a2f3587c4662f51c0f6 SHA512 a357fbd16cf653555bb624103732041efa80b1ae21a6347fdcb609de3cc58227ac053d21b62124fd77b21a16b19a2786bc1a8c33cc3b50dcffb3023bd6704f57
+DIST python-socks-2.5.0.gh.tar.gz 32293 BLAKE2B 20eaa8b27d695116f9d03bfa1807496c789a43804c06f441f7961d928095d169f9b581120c29d188e0eda39d15b517012647e6f6f682a29c260179dca422b0dc SHA512 d59a3eb851c80556e08513ae417a109da6670b81858df365818ca187d14b57719ee86c6a65d9e8a8366ad3c7a2516a10cabcbf9895d8456b5f188c80dae74eee
diff --git a/dev-python/python-socks/python-socks-2.5.0.ebuild b/dev-python/python-socks/python-socks-2.5.0.ebuild
new file mode 100644
index 000000000000..4bfe898288dd
--- /dev/null
+++ b/dev-python/python-socks/python-socks-2.5.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://github.com/romis2012/python-socks/
+ https://pypi.org/project/python-socks/
+"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# curio is not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+# TODO: revisit
+RDEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/anyio-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/async-timeout-3.0.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/tiny-proxy-0.1.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.16.0[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+# Test markers exist to exclude trio etc if needed
+distutils_enable_tests pytest