summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-08 02:23:33 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-08 19:40:14 +0200
commit5cbebf4bb675d87ecc6df4606c159c8862bd9353 (patch)
tree9274603b39ad965f2c96a5b275c976c4d699fc81 /dev-python/python-xcaplib
parentdev-python/python-application: initial import of version 1.5.0 (diff)
downloadgentoo-5cbebf4bb675d87ecc6df4606c159c8862bd9353.tar.gz
gentoo-5cbebf4bb675d87ecc6df4606c159c8862bd9353.tar.bz2
gentoo-5cbebf4bb675d87ecc6df4606c159c8862bd9353.zip
dev-python/python-xcaplib: initial import of version 1.1.0
Gentoo-Bug: 446198
Diffstat (limited to 'dev-python/python-xcaplib')
-rw-r--r--dev-python/python-xcaplib/Manifest1
-rw-r--r--dev-python/python-xcaplib/metadata.xml22
-rw-r--r--dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild25
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-xcaplib/Manifest b/dev-python/python-xcaplib/Manifest
new file mode 100644
index 000000000000..d375d1adf13f
--- /dev/null
+++ b/dev-python/python-xcaplib/Manifest
@@ -0,0 +1 @@
+DIST python-xcaplib-1.1.0.tar.gz 22892 SHA256 2f8ea6fe7d005104ef1d854aa87bd8ee85ca242a70cde42f409f8e5557f864b3 SHA512 140a12e39decdd15c06816cf5969baaf82437f010592ee2f4b7309db585aaa6611ab3af50e399bb18d216ae1586b5ebf18490d74c385a99d6673171bcf437395 WHIRLPOOL 711eb094be643613a117044d2c3ea054bf728ff21a1efe668d27bebe912c67463cb15b8e0c052699f01439a6631c2570ba1e79d452cc5250383200fb2f54830b
diff --git a/dev-python/python-xcaplib/metadata.xml b/dev-python/python-xcaplib/metadata.xml
new file mode 100644
index 000000000000..0dd9c1582327
--- /dev/null
+++ b/dev-python/python-xcaplib/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ XCAP protocol, defined in RFC 4825, allows a client to read, write,
+ and modify application configuration data stored in XML format on a
+ server. XCAP maps XML document sub-trees and element attributes to
+ HTTP URIs, so that these components can be directly accessed by HTTP.
+ An XCAP server used by XCAP clients to store data like presence
+ policy in combination with a SIP Presence server that supports
+ PUBLISH/SUBSCRIBE/NOTIFY SIP methods can provide a complete SIP
+ SIMPLE solution.
+
+ The XCAP client example script provided by this package can be used to
+ manage documents on an XCAP server.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
new file mode 100644
index 000000000000..e68c80ee93f2
--- /dev/null
+++ b/dev-python/python-xcaplib/python-xcaplib-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl,xml"
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for managing XML documents on XCAP server"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/XCAP/python-xcaplib-${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-application[${PYTHON_USEDEP}]
+"