summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-20 08:13:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-20 13:09:46 +0200
commitd0e59733143cfda13aa5e47fa5f41543841a9ea7 (patch)
tree3c8c7b6652c90a208dda6eb8dfdfc6d54ff071d7 /dev-python/python3-discogs-client
parentdev-python/trimesh: Bump to 3.22.5 (diff)
downloadgentoo-d0e59733143cfda13aa5e47fa5f41543841a9ea7.tar.gz
gentoo-d0e59733143cfda13aa5e47fa5f41543841a9ea7.tar.bz2
gentoo-d0e59733143cfda13aa5e47fa5f41543841a9ea7.zip
Rename dev-python/{discogs-client → python3-discogs-client}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python3-discogs-client')
-rw-r--r--dev-python/python3-discogs-client/Manifest1
-rw-r--r--dev-python/python3-discogs-client/metadata.xml21
-rw-r--r--dev-python/python3-discogs-client/python3-discogs-client-2.6.ebuild36
-rw-r--r--dev-python/python3-discogs-client/python3-discogs-client-9999.ebuild36
4 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/python3-discogs-client/Manifest b/dev-python/python3-discogs-client/Manifest
new file mode 100644
index 000000000000..da8896943c97
--- /dev/null
+++ b/dev-python/python3-discogs-client/Manifest
@@ -0,0 +1 @@
+DIST python3-discogs-client-2.6.tar.gz 36426 BLAKE2B 1d2ae337beb0aaf9cc7310b13909a0a9172c79813ccc0a581af5478cbf45b28d2654b963df2881ad858fcabd5e85594c9a41458283e9e2c9c90ed4d6ad57853c SHA512 2b2ed4a56337b184266832682f7fa4d8726cc414b89446b2a6e96131d82c01c60bd78ac3336bdf94a3077ea25a313fbd532ba574cad64ddc9ab0229d0d7e44b1
diff --git a/dev-python/python3-discogs-client/metadata.xml b/dev-python/python3-discogs-client/metadata.xml
new file mode 100644
index 000000000000..d0e42c50c28e
--- /dev/null
+++ b/dev-python/python3-discogs-client/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>guillaumeseren@gmail.com</email>
+ <name>Guillaume Seren</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">python3-discogs-client</remote-id>
+ <remote-id type="github">joalla/discogs_client</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python3-discogs-client/python3-discogs-client-2.6.ebuild b/dev-python/python3-discogs-client/python3-discogs-client-2.6.ebuild
new file mode 100644
index 000000000000..91d3ad2e00f5
--- /dev/null
+++ b/dev-python/python3-discogs-client/python3-discogs-client-2.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="python3-discogs-client"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="amd64 ~x86"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
diff --git a/dev-python/python3-discogs-client/python3-discogs-client-9999.ebuild b/dev-python/python3-discogs-client/python3-discogs-client-9999.ebuild
new file mode 100644
index 000000000000..3e47b3b4124c
--- /dev/null
+++ b/dev-python/python3-discogs-client/python3-discogs-client-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN="python3-discogs-client"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/joalla/discogs_client.git"
+ inherit git-r3
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Continuation of the official Python API client for Discogs"
+HOMEPAGE="
+ https://github.com/joalla/discogs_client/
+ https://pypi.org/project/python3-discogs-client/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/oauthlib[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest