summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-03 10:37:05 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-03 11:19:59 +0100
commit1b4109b06fe34ac39f3fc55996d66a9b6cc8d809 (patch)
treea964f0dc457a9e1830f379e2952eb3793784c93c /dev-python/qrcode/qrcode-5.1-r1.ebuild
parentdev-python/qrcode: Drop old (diff)
downloadgentoo-1b4109b06fe34ac39f3fc55996d66a9b6cc8d809.tar.gz
gentoo-1b4109b06fe34ac39f3fc55996d66a9b6cc8d809.tar.bz2
gentoo-1b4109b06fe34ac39f3fc55996d66a9b6cc8d809.zip
dev-python/qrcode: Backport fix for Python3
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=564930 Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/qrcode/qrcode-5.1-r1.ebuild')
-rw-r--r--dev-python/qrcode/qrcode-5.1-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/qrcode/qrcode-5.1-r1.ebuild b/dev-python/qrcode/qrcode-5.1-r1.ebuild
new file mode 100644
index 000000000000..e97bd1cf63d4
--- /dev/null
+++ b/dev-python/qrcode/qrcode-5.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="QR Code generator on top of PIL"
+HOMEPAGE="https://pypi.python.org/pypi/qrcode"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+# optional deps:
+# - pillow and lxml for svg backend, set as hard deps
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-unicode.patch
+)
+
+python_test() {
+ "${PYTHON}" -m unittest discover > /dev/tty | less || die "Testing failed with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman doc/qr.1
+}