summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-15 21:51:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-15 22:26:01 +0200
commitc68944dc8bec78cffb64c5f8c9974420230669fb (patch)
tree14ea11ac714a6eaccf73485ecc6fa1dfcf5d1a8c /dev-python/requests-cache
parentdev-python/requests-cache: Bump to 0.7.5 (diff)
downloadgentoo-c68944dc8bec78cffb64c5f8c9974420230669fb.tar.gz
gentoo-c68944dc8bec78cffb64c5f8c9974420230669fb.tar.bz2
gentoo-c68944dc8bec78cffb64c5f8c9974420230669fb.zip
dev-python/requests-cache: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.8.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 9c4b50f67c4d..d707c4a20b5a 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -5,3 +5,4 @@ DIST requests-cache-0.7.3.gh.tar.gz 1182825 BLAKE2B bc2b936f3b13388c23c344119a0a
DIST requests-cache-0.7.4.gh.tar.gz 1254975 BLAKE2B f0df6ac156665f8eed8850e153bfa3738d8c6677ff1613a54fcbf3208861c590e5e0ede3d5c30eeda36dcd709390402a020e03a0180e701e0751c5c982903a35 SHA512 684a3182135b6a31816629c8b4a174b52a629e964a5862573df1ac6e9e9b5cb807d1661a3a6daf8cc4b2a0f6778bd780d822a2f6c409242aa090c6565adf0aab
DIST requests-cache-0.7.5.gh.tar.gz 1254930 BLAKE2B 7dec609d8e5d5570247bc45c33763bc35006104082235575feb336d1d386a36d18ef1e4403703aa532bc5c8e1f7cf4f741aa91bb94be4bd1fd85fe7cc9adb9b1 SHA512 656791e54f7c8dfd6518054434aa4dd03e5ce027fb36b38675d99284536abefb11883f53c6ec2f11e3f8efb473f0d1e9cede100eac82005ee023b7778848f588
DIST requests-cache-0.8.0.gh.tar.gz 1642151 BLAKE2B e341707b2473438a8c4155350bce3e0fc712537692991e23965aa6504e8eed735caae8b103896bd324882a8f73f13f36b23b329c3c155864c1b7665c6bcc4e2a SHA512 b9f1769f70b33f128aacf05a2251f9d2511649a4e80cb702c14ac3fcbfaf72d1049a5792a295286b6969985320a0d5a87ef81bfe3bacbbc200042ba51889b7ea
+DIST requests-cache-0.8.1.gh.tar.gz 1540290 BLAKE2B ac9d7cdaa553400484776236b13f356e4e80a7c3aa5e63563dad860302cb421b7ceeb61e80af436cf9559467c4b2cd5e8363ae05e703661b88bf3ac04601ee30 SHA512 245ee7059afab50f32af9c8831fe11c14d5bd53fe6bbf02e5844974e0e5ea6c33e005f234485f245ee418ae03277c6e2cc41046a385ff138e58785cf37b119ea
diff --git a/dev-python/requests-cache/requests-cache-0.8.1.ebuild b/dev-python/requests-cache/requests-cache-0.8.1.ebuild
new file mode 100644
index 000000000000..61afa9af0454
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.8.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/cattrs[${PYTHON_USEDEP}]
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+ )
+ local EPYTEST_DESELECT=(
+ # Requires Internet access
+ tests/integration/test_compat.py::test_version_upgrade
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest
+}