summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-19 14:30:50 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-19 14:31:17 +0100
commit0f04fac543ae13dd64fa8ba4033b246d5387c9c6 (patch)
treeef8712a12e1df0055990ad90041030151a36ee35 /dev-python/scipy
parentdev-util/hipcc: Make implicit llvm dep explicit (diff)
downloadgentoo-0f04fac543ae13dd64fa8ba4033b246d5387c9c6.tar.gz
gentoo-0f04fac543ae13dd64fa8ba4033b246d5387c9c6.tar.bz2
gentoo-0f04fac543ae13dd64fa8ba4033b246d5387c9c6.zip
dev-python/scipy: Deselect timing out/hanging tests globally
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.11.3-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/scipy/scipy-1.11.3-r1.ebuild b/dev-python/scipy/scipy-1.11.3-r1.ebuild
index 7abc66ad2ceb..8796c0eb8138 100644
--- a/dev-python/scipy/scipy-1.11.3-r1.ebuild
+++ b/dev-python/scipy/scipy-1.11.3-r1.ebuild
@@ -110,6 +110,12 @@ python_test() {
# Crashes with assertion, not a regression
# https://github.com/scipy/scipy/issues/19321
scipy/signal/tests/test_signaltools.py::test_lfilter_bad_object
+
+ # timeouts
+ scipy/sparse/linalg/tests/test_propack.py::test_examples
+ # hang or incredibly slow
+ scipy/optimize/tests/test_lsq_linear.py::TestBVLS::test_large_rank_deficient
+ scipy/optimize/tests/test_lsq_linear.py::TestTRF::test_large_rank_deficient
)
local EPYTEST_IGNORE=()
@@ -122,13 +128,9 @@ python_test() {
case ${EPYTHON} in
pypy3)
EPYTEST_DESELECT+=(
- # TODO: fd leaks?
+ # fd leaks in tests
+ # https://github.com/scipy/scipy/issues/19553
scipy/fft/_pocketfft/tests/test_real_transforms.py
- # timeouts
- scipy/sparse/linalg/tests/test_propack.py::test_examples
- # hang or incredibly slow
- scipy/optimize/tests/test_lsq_linear.py::TestBVLS::test_large_rank_deficient
- scipy/optimize/tests/test_lsq_linear.py::TestTRF::test_large_rank_deficient
# TODO
'scipy/special/tests/test_data.py::test_boost[<Data for expi: expinti_data_long_ipp-expinti_data_long>]'
)