summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 12:41:20 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 12:41:20 +0200
commit6e04bcb7dba28218aba794b6e0737acf0891a510 (patch)
treec9f45b130212ce1e56fdbfea442e005daa70145b /dev-python/scipy
parentdev-python/pandas: Remove old (diff)
downloadgentoo-6e04bcb7dba28218aba794b6e0737acf0891a510.tar.gz
gentoo-6e04bcb7dba28218aba794b6e0737acf0891a510.tar.bz2
gentoo-6e04bcb7dba28218aba794b6e0737acf0891a510.zip
dev-python/scipy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/Manifest1
-rw-r--r--dev-python/scipy/files/scipy-1.7.1-pythran-tests-32-bit.patch31
-rw-r--r--dev-python/scipy/scipy-1.7.3.ebuild194
3 files changed, 0 insertions, 226 deletions
diff --git a/dev-python/scipy/Manifest b/dev-python/scipy/Manifest
index 87adcb9658aa..d49ac5272be8 100644
--- a/dev-python/scipy/Manifest
+++ b/dev-python/scipy/Manifest
@@ -1,4 +1,3 @@
-DIST scipy-1.7.3.tar.gz 36102562 BLAKE2B 9a605a45d8f03aae3411a6fa92e32c7f6d10373455493ead847d4ad01429b55dbbc33c1a0309d6c9d76d3e9ab1a06772df59c08d393377896c4b534599f9eb9b SHA512 83fe00cf708a13a08d28af7022ec645d8976c177f2fefb56e0a47bfcbec726330b973d1f44364e23c939ae708e239a05904346f515ea1a37e8b70ad160b81cee
DIST scipy-1.8.0.tar.gz 38313602 BLAKE2B 3f071ad3dfa350bba7eaf8e06c8bdb660f9dc1ef0e0bfc1eb1be2c400f947b2b26d62066a4b0f603ae56244131aff6e4c5b7e87cfd2aa7b278e3071062a4bf02 SHA512 674652728ae76479d17189e6974895bb838a8e83b17b9fb91c5f86faebf2a1387e1466555ac5b51d05c293f9b31b9a72e634f5858105ea984ca94bd2f05bbb4c
DIST scipy-html-1.7.1.zip 32435246 BLAKE2B fd8173da41aba95a14b1376f848bc668c4659bf1bbbdd0f87d926633d36f29c039957d38be145a5583010ebd83f6458090f75bdad773cc0f1591664e13c04c20 SHA512 ee59722878f6ef2d2319cdf4e6a60d3d1184f7c22752f9a8859eaa46fb677ebac9e8eef9c0826998e12bac9399e336799843341ef203224a82c9101347149672
DIST scipy-ref-1.7.1.pdf 33542025 BLAKE2B 6c978f06b770805f0fae06db740e8596658d98bbbc93c865127eae909957503bb38e02a9c97319aed07608718f8f373374b1cf3a8c3bd624aa3143f1d21bc428 SHA512 45720dc299594bac5c7539f950a0ff135b125d86bfe9847032cbff1f294601fefd0a1ac3fd7e3928b2702390c318ae2f8adca6403ba06ea1ded705fcff94ab79
diff --git a/dev-python/scipy/files/scipy-1.7.1-pythran-tests-32-bit.patch b/dev-python/scipy/files/scipy-1.7.1-pythran-tests-32-bit.patch
deleted file mode 100644
index 206d1d9fa3b2..000000000000
--- a/dev-python/scipy/files/scipy-1.7.1-pythran-tests-32-bit.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/scipy/scipy/commit/5b3a3b440525aa5038e2cead1f9b4f23a610cd9f
-
-From: serge-sans-paille <serge.guelton@telecom-bretagne.eu>
-Date: Sun, 18 Jul 2021 11:14:29 +0200
-Subject: [PATCH] Extra pythran annotation for i686 support
-
-Bug spotted on Fedora, see https://src.fedoraproject.org/rpms/scipy/pull-request/22
-
-The `int[::]` annotation is used to accept non-contiguous views.
---- a/scipy/optimize/_group_columns.py
-+++ b/scipy/optimize/_group_columns.py
-@@ -54,6 +54,8 @@ def group_dense(m, n, A):
-
- #pythran export group_sparse(int, int, intc[], intc[])
- #pythran export group_sparse(int, int, int[], int[])
-+#pythran export group_sparse(int, int, intc[::], intc[::])
-+#pythran export group_sparse(int, int, int[::], int[::])
- def group_sparse(m, n, indices, indptr):
- groups = -np.ones(n, dtype=np.intp)
- current_group = 0
---- a/scipy/signal/_max_len_seq_inner.py
-+++ b/scipy/signal/_max_len_seq_inner.py
-@@ -4,6 +4,7 @@
- import numpy as np
-
- #pythran export _max_len_seq_inner(intp[], int8[], int, int, int8[])
-+#pythran export _max_len_seq_inner(int[], int8[], int, int, int8[])
-
- # Fast inner loop of max_len_seq.
- def _max_len_seq_inner(taps, state, nbits, length, seq):
-
diff --git a/dev-python/scipy/scipy-1.7.3.ebuild b/dev-python/scipy/scipy-1.7.3.ebuild
deleted file mode 100644
index 3a3cfc929a8b..000000000000
--- a/dev-python/scipy/scipy-1.7.3.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
-
-# upstream is slacking forever with doc updates
-DOC_PV=1.7.1
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="https://www.scipy.org/"
-SRC_URI="
- mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
- doc? (
- https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${DOC_PV}.zip
- https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${DOC_PV}.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 -hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86"
-IUSE="doc +pythran sparse"
-
-DEPEND="
- >=dev-python/numpy-1.16.5[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack:0=
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack:0= )"
-RDEPEND="${DEPEND}
- dev-python/pillow[${PYTHON_USEDEP}]"
-BDEPEND="
- dev-lang/swig
- >=dev-python/cython-0.29.18[${PYTHON_USEDEP}]
- dev-python/pybind11[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- pythran? ( dev-python/pythran[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.7.1-pythran-tests-32-bit.patch
-)
-
-src_unpack() {
- default
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF || die
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
- cat >> setup.cfg <<-EOF || die
- [options]
- zip_safe = False
- EOF
-
- # TODO
- sed -e "s:== 'levy_stable':in ('levy_stable', 'crystalball', 'ncf'):" \
- -i scipy/stats/tests/test_continuous_basic.py || die
-
- # Skip known-failing test. Broken on all versions in Gentoo for years.
- # bug #743295
- sed -e 's:test_bisplev_integer_overflow:_&:' \
- -i scipy/interpolate/tests/test_fitpack.py || die
-
- # Skip a few 32-bit related failures
- if use x86 ; then
- # TODO: Tidy this up and switch to epytest
- sed -i -e 's:test_nd_axis_m1:_&:' \
- -e 's:test_nd_axis_0:_&:' \
- -e 's:test_maxiter_worsening:_&:' \
- -e 's:test_pdist_jensenshannon_iris:_&:' \
- -e 's:test_align_vectors_single_vector:_&:' \
- scipy/signal/tests/test_spectral.py \
- scipy/sparse/linalg/isolve/tests/test_iterative.py \
- scipy/spatial/tests/test_distance.py \
- scipy/spatial/transform/tests/test_rotation.py || die
- fi
-
- if has_version ">=sci-libs/lapack-3.10"; then
- sed -e 's:test_sort(:_&:' \
- -i scipy/linalg/tests/test_decomp.py || die
- sed -e 's:test_solve_discrete_are:_&:' \
- -i scipy/linalg/tests/test_solvers.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- export SCIPY_USE_PYTHRAN=$(usex pythran 1 0)
-
- # bug 721860
- test-flag-FC -fallow-argument-mismatch &&
- append-fflags -fallow-argument-mismatch
-}
-
-python_compile() {
- # FIXME: parallel python building fails, bug #614464
- export ORIGINAL_MAKEOPTS="${MAKEOPTS}"
- export MAKEOPTS=-j1
-
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile \
- ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}/lib" || die "no ${TEST_DIR} available"
-
- # Let's try using pytest again with xdist to speed things up.
- # Note that using pytest is required to avoid dying b/c of a
- # deprecation warning with distutils in Python 3.01.
- epytest -n "$(makeopts_jobs "${ORIGINAL_MAKEOPTS}" "$(get_nproc)")"
-
- # Old test runner
-# PYTHONPATH=. "${EPYTHON}" -c "
-#import scipy, sys
-#r = scipy.test('fast', verbose=2)
-#sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && \
- local DOCS=( "${DISTDIR}"/${PN}-ref-${DOC_PV}.pdf ) \
- local HTML_DOCS=( "${WORKDIR}"/html/. )
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
- python_optimize
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog " echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}