summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-02 19:16:45 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-02 19:43:38 +0200
commit888914501fcd81c9da1dda2a3f1be35a859ac43e (patch)
treee6d6fcd2c7adea2c895ce48446a73aabb6eb3f38 /dev-python/setproctitle/setproctitle-1.1.9.ebuild
parentdev-python/pkgconfig: Clean old versions up (diff)
downloadgentoo-888914501fcd81c9da1dda2a3f1be35a859ac43e.tar.gz
gentoo-888914501fcd81c9da1dda2a3f1be35a859ac43e.tar.bz2
gentoo-888914501fcd81c9da1dda2a3f1be35a859ac43e.zip
dev-python/setproctitle: Clean old versions up
Diffstat (limited to 'dev-python/setproctitle/setproctitle-1.1.9.ebuild')
-rw-r--r--dev-python/setproctitle/setproctitle-1.1.9.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/setproctitle/setproctitle-1.1.9.ebuild b/dev-python/setproctitle/setproctitle-1.1.9.ebuild
deleted file mode 100644
index 5274a1b502e0..000000000000
--- a/dev-python/setproctitle/setproctitle-1.1.9.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# pypy doesn't get started in test run. Still required by www-servers/gunicorn
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
-
-inherit distutils-r1 toolchain-funcs
-
-DESCRIPTION="Allow customization of the process title"
-HOMEPAGE="https://github.com/dvarrazzo/py-setproctitle"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# Required for re-write of test suite
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- # Make a nice html file
- rst2html.py README.rst > README.html
- # The README.rst will be duplicated in src_install
- rm README.rst || die
-}
-
-python_test() {
- # The suite via the Makefile appears to not cater to pypy
- [[ ${EPYTHON} =~ pypy ]] && return
-
- # prepare embedded executable
- emake \
- CC="$(tc-getCC)" \
- PYINC="$(python_get_CFLAGS)" \
- PYLIB="$(python_get_LIBS)" \
- check
-}