summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-13 15:25:18 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-13 16:03:38 -0600
commit86064bd815171a841cba6261bbbb061ffcc1c2f5 (patch)
tree9c8cdc483e9d496b425e7fe0659624085ce1be28 /dev-python/setuptools_scm
parentprofiles/arch/arm64: add mercurial use mask to setuptools_scm (diff)
downloadgentoo-86064bd815171a841cba6261bbbb061ffcc1c2f5.tar.gz
gentoo-86064bd815171a841cba6261bbbb061ffcc1c2f5.tar.bz2
gentoo-86064bd815171a841cba6261bbbb061ffcc1c2f5.zip
dev-python/setuptools_scm: splitting out test deps into use flags
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/setuptools_scm')
-rw-r--r--dev-python/setuptools_scm/metadata.xml3
-rw-r--r--dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild39
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/setuptools_scm/metadata.xml b/dev-python/setuptools_scm/metadata.xml
index 3aabcf579918..36c2a8fbd06e 100644
--- a/dev-python/setuptools_scm/metadata.xml
+++ b/dev-python/setuptools_scm/metadata.xml
@@ -10,4 +10,7 @@
<remote-id type="bitbucket">pypa/setuptools_scm</remote-id>
<remote-id type="github">pypa/setuptools_scm</remote-id>
</upstream>
+ <use>
+ <flag name="mercurial">Enables mercurial backend</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild b/dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild
new file mode 100644
index 000000000000..006c5a9012f6
--- /dev/null
+++ b/dev-python/setuptools_scm/setuptools_scm-1.15.6-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="package to manage versions by scm tags via setuptools"
+HOMEPAGE="https://github.com/pypa/setuptools_scm https://pypi.python.org/pypi/setuptools_scm"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="git mercurial test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ distutils_install_for_testing
+ py.test -v -v -x -k testing/test_basic_api.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_functions.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_main.py || die "tests failed under ${EPYTHON}"
+ py.test -v -v -x -k testing/test_regressions.py || die "tests failed under ${EPYTHON}"
+ if use git; then
+ py.test -v -v -x -k testing/test_git.py || die "tests failed under ${EPYTHON}"
+ fi
+ if use mercurial; then
+ py.test -v -v -x -k testing/test_mercurial.py || die "tests failed under ${EPYTHON}"
+ fi
+}