summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-10 13:58:36 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-10 14:02:51 +0100
commit8c09fe02d1c69ec2f3bc02395f57ad6b705f241f (patch)
tree3496d352d6e518bba541b08e5cf76a4984d79577 /dev-python/sexpdata
parentxfce-base/xfce4-power-manager: Bump to 4.18.1 (diff)
downloadgentoo-8c09fe02d1c69ec2f3bc02395f57ad6b705f241f.tar.gz
gentoo-8c09fe02d1c69ec2f3bc02395f57ad6b705f241f.tar.bz2
gentoo-8c09fe02d1c69ec2f3bc02395f57ad6b705f241f.zip
dev-python/sexpdata: Bump to 0.0.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sexpdata')
-rw-r--r--dev-python/sexpdata/Manifest1
-rw-r--r--dev-python/sexpdata/sexpdata-0.0.4.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sexpdata/Manifest b/dev-python/sexpdata/Manifest
index 55f10f72636c..1db82811e710 100644
--- a/dev-python/sexpdata/Manifest
+++ b/dev-python/sexpdata/Manifest
@@ -1 +1,2 @@
DIST sexpdata-0.0.3.tar.gz 13105 BLAKE2B 36c4082a63f6748759d71fc38a056ecb7467eafebf0a1a0b006fbef1302488f23a859462c9526dc365f7c88b8b6c331dc6e4892e1d96358abb44ca60a909d283 SHA512 03d4d1557bcc950124e408d6870894c8ee9e72a2ee83c881adf48f8e53bdf3744b4f3e3e133a74a195d236424b434cc690583a68d8395324ca4e84947e548501
+DIST sexpdata-0.0.4.gh.tar.gz 16489 BLAKE2B 56a8140fdc92c5802f4c4dc0b699c1492bc7c27aa5999f10a60c5da3ab1f0bcc8875c00ec30c7129064267d63fe21375818b19d0f554d5db5d77936c46c9dc2f SHA512 c3d542000f15ec2220bc5cbff07633ae690fdc676b71d447290f5e20f5930d84840c92cc5827d0dd848f63740ad8edec9583f98df11214a867b212282d5a7236
diff --git a/dev-python/sexpdata/sexpdata-0.0.4.ebuild b/dev-python/sexpdata/sexpdata-0.0.4.ebuild
new file mode 100644
index 000000000000..641292ff7ba9
--- /dev/null
+++ b/dev-python/sexpdata/sexpdata-0.0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="a simple S-expression parser/serializer"
+HOMEPAGE="
+ https://github.com/jd-boyd/sexpdata/
+ https://pypi.org/project/sexpdata/
+"
+SRC_URI="
+ https://github.com/jd-boyd/sexpdata/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:install_requires\.append.*:pass:' setup.py || die
+ distutils-r1_src_prepare
+}