summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Mokry <martin-kokos@users.noreply.github.com>2023-03-28 20:45:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-07 16:01:24 +0200
commita438cecf00717458f1a8c790370191cbe7fdfd54 (patch)
tree1efeb1093e7be8ce620968abf0c4c02c39987663 /dev-python/shellingham
parentdev-python/orjson: New package, v3.8.9 (diff)
downloadgentoo-a438cecf00717458f1a8c790370191cbe7fdfd54.tar.gz
gentoo-a438cecf00717458f1a8c790370191cbe7fdfd54.tar.bz2
gentoo-a438cecf00717458f1a8c790370191cbe7fdfd54.zip
dev-python/shellingham: New package, v1.5.0
Signed-off-by: Martin Mokry <martin-kokos@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shellingham')
-rw-r--r--dev-python/shellingham/Manifest1
-rw-r--r--dev-python/shellingham/metadata.xml13
-rw-r--r--dev-python/shellingham/shellingham-1.5.0.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/shellingham/Manifest b/dev-python/shellingham/Manifest
new file mode 100644
index 000000000000..8fe740232d11
--- /dev/null
+++ b/dev-python/shellingham/Manifest
@@ -0,0 +1 @@
+DIST shellingham-1.5.0.gh.tar.gz 21078 BLAKE2B 94469e640b6827312d5efde90916d41d4c33c24738e0dfb5c80aff8d16b858936e6b0d2f90dd5d69ee3b5698196df1c4e475685279eb978b7dd0afba67fa5d5d SHA512 2f73acdb30da499493bb79a3db24133f5bcb88d4d755387a81bc04ec30fe91ca44761d7d49fe793495b09f1c34ff59ef320a1e001cf5628ddc62885c05466076
diff --git a/dev-python/shellingham/metadata.xml b/dev-python/shellingham/metadata.xml
new file mode 100644
index 000000000000..aed35119921c
--- /dev/null
+++ b/dev-python/shellingham/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">shellingham</remote-id>
+ <remote-id type="github">sarugaku/shellingham</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/shellingham/shellingham-1.5.0.ebuild b/dev-python/shellingham/shellingham-1.5.0.ebuild
new file mode 100644
index 000000000000..be6e6357e080
--- /dev/null
+++ b/dev-python/shellingham/shellingham-1.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tool to Detect Surrounding Shell"
+HOMEPAGE="
+ https://github.com/sarugaku/shellingham/
+ https://pypi.org/project/shellingham/
+"
+# Missing tests in PYPI distribution so we use the GH package
+SRC_URI="
+ https://github.com/sarugaku/shellingham/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest