summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-07 08:04:24 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-07 08:04:24 +0200
commitb3fd80873057a4d22397d172d065c3c35e1ed106 (patch)
treef1b2c4e4a5089d8a44fff2ca32e16c6183b172c0 /dev-python/sphinx
parentdev-python/ipykernel: Bump to 5.3.1 (diff)
downloadgentoo-b3fd80873057a4d22397d172d065c3c35e1ed106.tar.gz
gentoo-b3fd80873057a4d22397d172d065c3c35e1ed106.tar.bz2
gentoo-b3fd80873057a4d22397d172d065c3c35e1ed106.zip
dev-python/sphinx: Bump to 3.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx')
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/sphinx-3.1.2.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index 524f91b1ac87..3b0316a978b4 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -5,3 +5,4 @@ DIST Sphinx-3.0.3.tar.gz 5905054 BLAKE2B 048e449603f171d72b24be5bc0fca3465819e78
DIST Sphinx-3.0.4.tar.gz 5909229 BLAKE2B 892b435642be2a6334f93d9f230ec1aeeff8cf7b374570aae66eb341614d4318125920ef0c5593e7eee64e0b8781f035635af71aac34e9c2c6eb20a07ed68d48 SHA512 ec0c2487f098f774452b58d4fb67be7850b4a54b80f2b01dcee990298f59bfede3ca43b28fa992181cdceb07f261abce186862afd75c889c6682338049db6288
DIST Sphinx-3.1.0.tar.gz 5931678 BLAKE2B 63f9d78ea46832fc9ca7122826888abb5b8a6be55e6b3e9015a34bc4186b0544a6c5429be010622fb4794b720a6675b3a89f101446e36327819d5db07dceaa03 SHA512 8660061f3617b00eaf19655256d1b164eb24cc10c7c8016e32cd28d1f81903ef8def0c5da202066c477448f4ac6d764dbd8b1b7179edcb9d00925e35596c4714
DIST Sphinx-3.1.1.tar.gz 5932445 BLAKE2B d98d4e1d546a60217779a071d642cef8c4b703715e212344d904fc343928afe4b21722d953afb67add0c0390633f3c2159b2235d0a5dd0148946ebfbf473c215 SHA512 0c97cab085b1d8152cefde73a7e2116e83426a1ff071c8be9b37ae8e8cf82e9abefacad2cb37a86e1754fbdf57a8dc05ee3041d7dde506fa103babb82c380293
+DIST Sphinx-3.1.2.tar.gz 5934433 BLAKE2B 4ed04dcff4db412ea1f749c0b90d0c38197bbc95607bcc719522f0690d6fd58aa59b87a053c036e9b3c982e9c0f6fa9b6b67f903cb7d9e6fea3a13d99b7be297 SHA512 d1b55a603ea4a76d2315e170b8ba7858caf1658660e9983034918bd265c505f0e5157ab9d9cebc970261646ae0959e1cf75562b01b73bf3a380e712393a735b9
diff --git a/dev-python/sphinx/sphinx-3.1.2.ebuild b/dev-python/sphinx/sphinx-3.1.2.ebuild
new file mode 100644
index 000000000000..02e54fb7e8fd
--- /dev/null
+++ b/dev-python/sphinx/sphinx-3.1.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python documentation generator"
+HOMEPAGE="https://www.sphinx-doc.org/
+ https://github.com/sphinx-doc/sphinx"
+SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc latex test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/imagesize[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/snowballstemmer[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-htmlhelp[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-serializinghtml[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typed-ast[${PYTHON_USEDEP}]
+ ' python3_{6,7})
+ latex? (
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+BDEPEND="
+ doc? (
+ dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/imagemagick-tools[jpeg,png,svg]
+ dev-texlive/texlive-fontsextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-luatex
+ app-text/dvipng
+ )"
+
+S="${WORKDIR}/${P^}"
+
+python_prepare_all() {
+ # remove tests that fail due to network-sandbox
+ rm tests/test_build_linkcheck.py || die "Failed to remove web tests"
+ sed -i -e 's:test_latex_images:_&:' tests/test_build_latex.py || die
+
+ # fail under pypy3 (some because of missing typed-ast)
+ # revisit when pypy3 becomes pypy3.8
+ sed -i -e '/def test_partialfunction/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_autodoc_typed_instance_variables/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_autodoc_inherited_members_None/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_cython/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_automethod_for_builtin/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ tests/test_ext_autodoc.py || die
+ sed -i -e '/import pytest/aimport sys' \
+ -e '/def test_builtin_function/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_methoddescriptor/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ -e '/def test_wrapped_function/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ tests/test_ext_autodoc_autofunction.py || die
+ sed -i -e '/import pytest/aimport sys' \
+ -e '/def test_autodoc_typehints_signature/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ tests/test_ext_autodoc_configs.py || die
+ sed -i -e '/import pytest/aimport sys' \
+ -e '/def test_autosummary_generate_content_for_module/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ tests/test_ext_autosummary.py || die
+ sed -i -e '/def test_annotated_assignment_py36/i\
+@pytest.mark.skipif(hasattr(sys, "pypy_version_info"), reason="broken on pypy3")' \
+ tests/test_pycode_parser.py || die
+
+ # disable internet access
+ sed -i -e 's:^intersphinx_mapping:disabled_&:' \
+ doc/conf.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ distutils-r1_python_compile
+
+ # Generate the grammar. It will be caught by install somehow.
+ # Note that the tests usually do it for us. However, I don't want
+ # to trust USE=test really running all the tests, especially
+ # with FEATURES=test-fail-continue.
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" -m sphinx.pycode.__init__ || die "Grammar generation failed."
+ popd >/dev/null || die
+}
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx
+ HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ fi
+}
+
+python_test() {
+ mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
+ local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}