summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-03 18:20:08 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-03 18:30:47 +0100
commit699627899653c31e72608e1f8c58153f50cf7358 (patch)
tree91cf049f607992e33ff909953ae846f4ffa2a16a /dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild
parentdev-python/repoze-sphinx-autointerface: Remove namespace dep (diff)
downloadgentoo-699627899653c31e72608e1f8c58153f50cf7358.tar.gz
gentoo-699627899653c31e72608e1f8c58153f50cf7358.tar.bz2
gentoo-699627899653c31e72608e1f8c58153f50cf7358.zip
dev-python/sphinxcontrib-applehelp: Remove namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild')
-rw-r--r--dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..d3bc11934e2a
--- /dev/null
+++ b/dev-python/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Apple help book"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-applehelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}