summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-28 05:21:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-28 06:03:40 +0200
commit7643aea7c83dfc12adcf2669bdd525be83d64270 (patch)
tree797f2eb467ae2b8d930ce8a4f79454c4706865b4 /dev-python/suds-community/suds-community-1.1.2.ebuild
parentapp-admin/awscli: Bump to 1.25.18 (diff)
downloadgentoo-7643aea7c83dfc12adcf2669bdd525be83d64270.tar.gz
gentoo-7643aea7c83dfc12adcf2669bdd525be83d64270.tar.bz2
gentoo-7643aea7c83dfc12adcf2669bdd525be83d64270.zip
dev-python/suds-community: Bump to 1.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/suds-community/suds-community-1.1.2.ebuild')
-rw-r--r--dev-python/suds-community/suds-community-1.1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/suds-community/suds-community-1.1.2.ebuild b/dev-python/suds-community/suds-community-1.1.2.ebuild
new file mode 100644
index 000000000000..a41f925a470f
--- /dev/null
+++ b/dev-python/suds-community/suds-community-1.1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_REQ_USE="xml(+)"
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lightweight SOAP client"
+HOMEPAGE="
+ https://github.com/suds-community/suds/
+ https://pypi.org/project/suds-community/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( README.md notes/. )
+
+BDEPEND="
+ test? (
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest