summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-25 06:23:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-25 10:01:41 +0200
commit0c6de2c357b3b457c06b521ea4cf1ab1de316ed7 (patch)
treeb769a512fb0a7946d9f623104f9352ee1678a862 /dev-python/unearth
parentdev-python/uv: Remove old (diff)
downloadgentoo-0c6de2c357b3b457c06b521ea4cf1ab1de316ed7.tar.gz
gentoo-0c6de2c357b3b457c06b521ea4cf1ab1de316ed7.tar.bz2
gentoo-0c6de2c357b3b457c06b521ea4cf1ab1de316ed7.zip
dev-python/unearth: Bump to 0.15.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest1
-rw-r--r--dev-python/unearth/unearth-0.15.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index c4ac662ecf38..9a57f3ed3266 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,2 +1,3 @@
DIST unearth-0.15.3.tar.gz 283726 BLAKE2B a805720628c10f7594b8deee3b9fa9a922c5c85143ddb80d863a4aee3f8524360339540ca035060d5f46534fcc93472d07dd40dfb7712cffd3e5e17b74128c70 SHA512 68cde14908a471e0d1d8c75eb33ec352f4d90d6f54692c21039315961b906c90220fc718881c9e0937a34677e05835108bca1298aa0c825dd0666bb84529f100
DIST unearth-0.15.4.tar.gz 283788 BLAKE2B 57d3da264e8a0574bf8b208cee87a9fab6778eb9e9da0a0697a91bffebc28c27d62b5d22584b02049684269709012a060d075f62887bb8685989b07745c80da6 SHA512 a6f759108ec0bdddafd653cff840549a57d9656af2c768b2bdf745f5e9d0688c4f14ca0bb8ed86ffa8d38cb9e0a8cdcdb076db0585df3734131f24ef0cc5c995
+DIST unearth-0.15.5.tar.gz 283787 BLAKE2B 2910be23141eb0a683766e83eae1cd35a074b98aaba7c25f49f06a321c261583a65bcb2cbd56c129efc1551e2f421e29dde784d3689c0dfc45d420c870a9b112 SHA512 84851788cd6bf6743307bb5a49fff1b6eeadd3f73605f4b2f7ffe1720d50713971d7cf020e17f34bbe755f523400a6149ace9add1c680bb955f6b46e8e092cba
diff --git a/dev-python/unearth/unearth-0.15.5.ebuild b/dev-python/unearth/unearth-0.15.5.ebuild
new file mode 100644
index 000000000000..a135cb39bbf1
--- /dev/null
+++ b/dev-python/unearth/unearth-0.15.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.27.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -p pytest_mock
+}