summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/webut
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/webut')
-rw-r--r--dev-python/webut/Manifest1
-rw-r--r--dev-python/webut/metadata.xml5
-rw-r--r--dev-python/webut/webut-0.1.0.2-r1.ebuild31
-rw-r--r--dev-python/webut/webut-0.1.0.2.ebuild39
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/webut/Manifest b/dev-python/webut/Manifest
new file mode 100644
index 000000000000..8f0a74d26bc4
--- /dev/null
+++ b/dev-python/webut/Manifest
@@ -0,0 +1 @@
+DIST webut_0.1-0.2.tar.gz 11142 SHA256 e133b6d8cd8d0c46290a2de3f59cb8f8ffb17301bf86fb5d318ad0ad21fea73b SHA512 14801e3546e17f07328faee1df6708050702de75454e4eb2ad1fca2d72faf9a3228082f3d82a01a2810ba0fe15dacaee8fb556adff811596a1349eea61faeaed WHIRLPOOL 6d2455c75ce02f9aecc9f182e7b209b3df76a70a9b0518f11d5c4d9f7147a35b511f63fab9ced584938511a3c7cb8918bb670f12c2ec8e0654475a4ddf6eb939
diff --git a/dev-python/webut/metadata.xml b/dev-python/webut/metadata.xml
new file mode 100644
index 000000000000..301d2207cc29
--- /dev/null
+++ b/dev-python/webut/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/webut/webut-0.1.0.2-r1.ebuild b/dev-python/webut/webut-0.1.0.2-r1.ebuild
new file mode 100644
index 000000000000..7bef4ed25200
--- /dev/null
+++ b/dev-python/webut/webut-0.1.0.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+MY_P=${PN}_$(replace_version_separator 2 '-')
+
+DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
+HOMEPAGE="http://www.inoi.fi/open/trac/webut"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/nevow-0.9.18[${PYTHON_USEDEP}]
+ >=dev-python/twisted-core-2[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-3.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/webut/webut-0.1.0.2.ebuild b/dev-python/webut/webut-0.1.0.2.ebuild
new file mode 100644
index 000000000000..4031e1365a00
--- /dev/null
+++ b/dev-python/webut/webut-0.1.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_P=${PN}_$(replace_version_separator 2 '-')
+
+DESCRIPTION="Miscellaneous utilities for nevow and twisted.web programming"
+HOMEPAGE="http://www.inoi.fi/open/trac/webut"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="examples"
+
+RDEPEND=">=dev-python/nevow-0.9.18
+ >=dev-python/twisted-core-2
+ >=dev-python/zope-interface-3.0.1"
+DEPEND="${RDEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${PN}-$(get_version_component_range 1-2)"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ rm -rf "${D}/examples"
+}