summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-14 07:55:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-14 13:50:19 +0200
commit58fc55d8aa4374a76ddd2d866c9f02daad09bcdd (patch)
treef1ba0aa73f315d1f81c4864b27dfdf32bcea2768 /dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild
parentxfce-base/xfce4-session: Bump to 4.15.0 (diff)
downloadgentoo-58fc55d8aa4374a76ddd2d866c9f02daad09bcdd.tar.gz
gentoo-58fc55d8aa4374a76ddd2d866c9f02daad09bcdd.tar.bz2
gentoo-58fc55d8aa4374a76ddd2d866c9f02daad09bcdd.zip
dev-python/xlsxwriter: Bump to 1.3.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild')
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild b/dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild
new file mode 100644
index 000000000000..11100a0ce79a
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-1.3.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PN="XlsxWriter"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="https://github.com/jmcnamara/XlsxWriter"
+SRC_URI="https://github.com/jmcnamara/XlsxWriter/archive/RELEASE_${PV}.tar.gz -> ${P}-tests.tar.gz"
+S="${WORKDIR}/${MY_PN}-RELEASE_${PV}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest