summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-03 20:12:05 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-03 20:30:12 +0300
commitfa44a2f0245cfb7b09cd80e4c61c067afe332e9f (patch)
tree689a2a3b2b98188026752b481653f9fdef1fc062 /dev-python/yappi/yappi-1.3.6.ebuild
parentdev-python/ubelt: add 1.2.0 (diff)
downloadgentoo-fa44a2f0245cfb7b09cd80e4c61c067afe332e9f.tar.gz
gentoo-fa44a2f0245cfb7b09cd80e4c61c067afe332e9f.tar.bz2
gentoo-fa44a2f0245cfb7b09cd80e4c61c067afe332e9f.zip
dev-python/yappi: add 1.3.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/yappi/yappi-1.3.6.ebuild')
-rw-r--r--dev-python/yappi/yappi-1.3.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/yappi/yappi-1.3.6.ebuild b/dev-python/yappi/yappi-1.3.6.ebuild
new file mode 100644
index 000000000000..699a13380131
--- /dev/null
+++ b/dev-python/yappi/yappi-1.3.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}