summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-08 05:16:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-08 05:52:31 +0100
commit86c56d1b74ecfe12015ef0b7c2bea3cf2ff048e5 (patch)
treebabd24e4cb3cfa9eb78f6cdad2a9fbaaaed4e316 /dev-python/yappi
parentdev-lang/ispc: Bump to 1.25.3 (diff)
downloadgentoo-86c56d1b74ecfe12015ef0b7c2bea3cf2ff048e5.tar.gz
gentoo-86c56d1b74ecfe12015ef0b7c2bea3cf2ff048e5.tar.bz2
gentoo-86c56d1b74ecfe12015ef0b7c2bea3cf2ff048e5.zip
dev-python/yappi: Bump to 1.6.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yappi')
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.6.9.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index 5c51299da9ec..a4f8daf9d486 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-1.6.0.gh.tar.gz 938098 BLAKE2B 7d5ad3066647419502ce43a2577509dbfc2ba898a8a68187a0e2efa2868764139c5a0bde873eb270f4acbb98749ee770e0cd00d24079318ab291dd5becc7a00e SHA512 d6b9e30129d83ab24ac80732e6a31e7dcc9e7e0f8bedc39cd578b73b12007c38db6c5b101e4364d3d129ba24bb0adaae71bc48827ac577c8ef96c9a557a9d80f
+DIST yappi-1.6.9.gh.tar.gz 938153 BLAKE2B a14f7cc20a53b7e8b03544cad81c2d35e8874e15b6a4ef69b3fbaf06343e12a89513f768e62a2e91869175eaff4636caa4e60663caea56e1ca68cc85bdd36deb SHA512 c75e8911772473adb534b5b9afcde7053d73398b30938b8a64aa2d5af12c26618aca90d871f4fdd30f06ec58966931ae5088d4946cf0779e24e5be9f68e1ac22
diff --git a/dev-python/yappi/yappi-1.6.9.ebuild b/dev-python/yappi/yappi-1.6.9.ebuild
new file mode 100644
index 000000000000..c96c9bcafc47
--- /dev/null
+++ b/dev-python/yappi/yappi-1.6.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}