summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-19 09:53:57 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-19 09:53:57 +0200
commit2ab083b98fa4cc07a551b69f2c707443254ed2cb (patch)
treec182561cc3a2a1268c72e0a1a308b8eb295c2c33 /dev-python
parentdev-python/jinja2_pluralize: Add python@ as co-maint. (diff)
downloadgentoo-2ab083b98fa4cc07a551b69f2c707443254ed2cb.tar.gz
gentoo-2ab083b98fa4cc07a551b69f2c707443254ed2cb.tar.bz2
gentoo-2ab083b98fa4cc07a551b69f2c707443254ed2cb.zip
dev-python/timeout-decorator: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/timeout-decorator/timeout-decorator-0.5.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/timeout-decorator/timeout-decorator-0.5.0-r1.ebuild b/dev-python/timeout-decorator/timeout-decorator-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..172786f8e4bd
--- /dev/null
+++ b/dev-python/timeout-decorator/timeout-decorator-0.5.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=9fbc3ef5b6f8f8cba2eb7ba795813d6ec543e265
+MY_P=${PN}-${EGIT_COMMIT}
+
+DESCRIPTION="Timeout decorator"
+HOMEPAGE="
+ https://github.com/pnpnpn/timeout-decorator/
+ https://pypi.org/project/timeout-decorator/
+"
+SRC_URI="
+ https://github.com/pnpnpn/timeout-decorator/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest