summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-11-20 12:13:45 -0600
committerNowa Ammerlaan <nowa@gentoo.org>2024-11-20 21:29:39 +0100
commit5bfb8c666ce98c5b02cb844105252916c957134a (patch)
tree645db9e709050fa4cb03c2fc70cf1492710fa3c8 /dev-python
parentdev-ml/spdx_licenses: new package, add 1.2.0 (diff)
downloadgentoo-5bfb8c666ce98c5b02cb844105252916c957134a.tar.gz
gentoo-5bfb8c666ce98c5b02cb844105252916c957134a.tar.bz2
gentoo-5bfb8c666ce98c5b02cb844105252916c957134a.zip
dev-python/zenlib: Add 2.4.1
Signed-off-by: Zen <z@pyl.onl> Closes: https://github.com/gentoo/gentoo/pull/39389 Signed-off-by: Nowa Ammerlaan <nowa@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zenlib/Manifest1
-rw-r--r--dev-python/zenlib/zenlib-2.4.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/zenlib/Manifest b/dev-python/zenlib/Manifest
index 56784a553d4b..574d7166b289 100644
--- a/dev-python/zenlib/Manifest
+++ b/dev-python/zenlib/Manifest
@@ -1 +1,2 @@
DIST zenlib-2.3.2.gh.tar.gz 20508 BLAKE2B 78ab80cbd1c4c71045900f6ddf3896a743fec2780a1645a7f10fd5678574cc68972321c28ae69b2fa60bcc6292691421c24e0b5c1c8326577d0a6e19a9a098b6 SHA512 08fec47999cf56d8db2bd585f9246708a0c566b529d9ddb49daca8c97a3b2e188217513087ede0c36d8182ff088d37483bc14539a35f51d2aca5d897c7479a99
+DIST zenlib-2.4.1.gh.tar.gz 21281 BLAKE2B e6a4005d7e5db95ccc18ecb87c10180e148bcf0a860923ac71177c90d448186247e08eee9f2c5dcb7e0803536dc07bfa3137b363a410ea2e03f875c4096fdadc SHA512 a8ceadbda243583ebe45fb56a4a72d2693505d9123346b3a140ccb16ed7de85d60caafffac0274e3f6289b0b82a82643feba039d85ea4f159fb259c7bdd46725
diff --git a/dev-python/zenlib/zenlib-2.4.1.ebuild b/dev-python/zenlib/zenlib-2.4.1.ebuild
new file mode 100644
index 000000000000..cd63c6cb8120
--- /dev/null
+++ b/dev-python/zenlib/zenlib-2.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Useful python decorators and utilities"
+HOMEPAGE="https://github.com/desultory/zenlib/"
+SRC_URI="
+ https://github.com/desultory/zenlib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+distutils_enable_tests unittest
+
+python_test() {
+ eunittest tests
+}