summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-20 07:47:57 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-20 08:55:47 +0100
commitb153857864393a6cdbe0a6caedaeed06fd7aee7b (patch)
treef552b2681559f1c14e10881560472fe13b729fa3 /dev-python
parentdev-python/botocore: Bump to 1.35.65 (diff)
downloadgentoo-b153857864393a6cdbe0a6caedaeed06fd7aee7b.tar.gz
gentoo-b153857864393a6cdbe0a6caedaeed06fd7aee7b.tar.bz2
gentoo-b153857864393a6cdbe0a6caedaeed06fd7aee7b.zip
dev-python/boto3: Bump to 1.35.65
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.65.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index bbd170f4bf96..9a2c430dd064 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.35.54.gh.tar.gz 882727 BLAKE2B 398e7743d30700856b15440c217d40e88aec
DIST boto3-1.35.57.gh.tar.gz 885077 BLAKE2B 4f3a29db5e76c706fbfd0afb3ec05d5518e69f3fd26d15e79024fb898d874818fa21031187d66078a4ebd107cce9461000e37506886f337049bd821e20933563 SHA512 19f951c04452203c070243bd8c944183221b51d9853efc19d33002af57c7d59c1967e8a7b606e56f772f35576ec6e1b52e2037138ba01a28f13685a49458c7d4
DIST boto3-1.35.63.gh.tar.gz 891481 BLAKE2B 092f4380aa31e57b3c8f6ef41ea8f0a4272e55f7a71762a532f338482f08782a11d57bdbc9af3630348706c4009bd0d3cd56ef4b2f1394d2d003638717cef860 SHA512 4deab7682b0f4d80a4aa12a8660b7263908411bd8f38692f9fa8820c6a18a4ecc3443e7524794282a0c0f38a4b94a1d09b6737e84ff3e01b9c8ac93abca2a9ce
DIST boto3-1.35.64.gh.tar.gz 892807 BLAKE2B bf2b899bfa3163efe20851079e764d99ccaf9c4a3555cc653363b42e018b9c5ce3bf3977d4fa0662de80c4163c4a97ff61842220d1cf21f6ff77c196fa6f6915 SHA512 3cb1f8ce15b2c7a977341c2f4338da6afa00ce359156bc48408d8f3c984a3ce8fc0da04c6897feb6e73bd4a5435d2b71a8f0e4d249880055ceda7b3e223a2889
+DIST boto3-1.35.65.gh.tar.gz 894025 BLAKE2B 378eef8673f3ed9a6d1495d0c4182679edb7671bd358d6041cba955a7a59954a9f516dfe371080926da669c14a4d47179ed22ffb326fb60ac6782e4d4f6963f0 SHA512 ad2335b0b18915971f49d44249d87808ed7b70977b30894070df941e3a84d9acb215f95ed7176f97faf8a9065c039ac0919dd8500114f1cf2d55169fb989d5e0
diff --git a/dev-python/boto3/boto3-1.35.65.ebuild b/dev-python/boto3/boto3-1.35.65.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.65.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}