summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-21 23:00:55 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-21 23:00:55 -0800
commitc4e0bd8268986a0a17abfda3735705431c746d54 (patch)
tree31bcba7d99658ca16779d9bd2f4d8ca2d46a6362 /dev-python
parentmedia-libs/mesa: Drop old versions (diff)
downloadgentoo-c4e0bd8268986a0a17abfda3735705431c746d54.tar.gz
gentoo-c4e0bd8268986a0a17abfda3735705431c746d54.tar.bz2
gentoo-c4e0bd8268986a0a17abfda3735705431c746d54.zip
dev-python/pytest-timeout: Version bump to 0.5.0, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch25
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild29
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index cd55de718da7..fe0a7846c6e2 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,2 +1,3 @@
DIST pytest-timeout-1.2.0.tar.gz 13258 BLAKE2B 71c137fb0440c15cc8285b4bef51405a6b53deb850c109d1a892159e8758c712e9d1bae8f400adadf1b85cf399c0b87bd2cab51d959b4eb68023052f6c42788c SHA512 b86548843e9ff8c8f7d1c39735025cdfa98befe2860e2a8a5d422d08bd7f542032384f147125a2a2841268154cc3a3874ef0aa4765d454fd5390edb773b106ae
DIST pytest-timeout-1.2.1.tar.gz 11498 BLAKE2B 65b50ed52409ed0031c7c9b07ef5b96c088cdf98c0155c1a6405e701fbddc2da1070a9f5a63e22428bd2d18e0ad4eec4050239f7d786fa854256c86eb6be0b1b SHA512 749a0dad83b82e93a97a8590900f2285679ec368612fdcfe3f5f7a5b64774ac85196dc31df111c6a99efda92dc03f751f17ec20862bed1f6aea7d7e4140a06bb
+DIST pytest-timeout-1.3.3.tar.gz 11627 BLAKE2B e20348cc461ad03e95c22a16e753b72441ee70da9769214f4d07db15818a8997339ced47244b15de62a61107eb749dff8d6f41ddb4720c925ef1e6eb9962db27 SHA512 633f5aee550d568e403b958f4490ecb828eb322811c9f18cfefb26613be4fc36da14232ecbef8666fcf2dc693a93674c00a853ab546ea8328a07ea34da79fb84
diff --git a/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch b/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch
new file mode 100644
index 000000000000..d3fa9ca0fd34
--- /dev/null
+++ b/dev-python/pytest-timeout/files/pytest-timeout-1.3.3-tests.patch
@@ -0,0 +1,25 @@
+diff -ur pytest-timeout-1.3.3.orig/test_pytest_timeout.py pytest-timeout-1.3.3/test_pytest_timeout.py
+--- pytest-timeout-1.3.3.orig/test_pytest_timeout.py 2018-11-16 03:41:33.000000000 -0800
++++ pytest-timeout-1.3.3/test_pytest_timeout.py 2019-11-21 22:34:08.429287370 -0800
+@@ -1,4 +1,5 @@
+ import os
++import platform
+ import os.path
+ import signal
+ import time
+@@ -93,6 +94,6 @@
+ # assert 'Timeout' in result.stdout.str() + result.stderr.str()
+
+
+-@pytest.mark.parametrize('meth', [have_sigalrm('signal'), 'thread'])
++@pytest.mark.parametrize('meth', [pytest.param('signal', marks=have_sigalrm), 'thread'])
+ @pytest.mark.parametrize('scope', ['function', 'class', 'module', 'session'])
+ def test_fix_setup(meth, scope, testdir):
+@@ -133,6 +134,6 @@
+ assert 'Timeout' not in result.stdout.str() + result.stderr.str()
+
+
+-@pytest.mark.parametrize('meth', [have_sigalrm('signal'), 'thread'])
++@pytest.mark.parametrize('meth', [pytest.param('signal', marks=have_sigalrm), 'thread'])
+ @pytest.mark.parametrize('scope', ['function', 'class', 'module', 'session'])
+ def test_fix_finalizer(meth, scope, testdir):
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild
new file mode 100644
index 000000000000..dcf68e3fb7b6
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7,8}} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+PATCHES=(
+ "${FILESDIR}/pytest-timeout-1.3.3-tests.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}