summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 06:09:37 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 07:17:56 +0200
commitd69b5d7550ca3a4ea7099fc9f4b3b08ca3b30e65 (patch)
tree710d559f6dda155c9b54412f02e2e36fe2dd3223 /dev-python
parentdev-python/bitarray: Bump to 2.7.5 (diff)
downloadgentoo-d69b5d7550ca3a4ea7099fc9f4b3b08ca3b30e65.tar.gz
gentoo-d69b5d7550ca3a4ea7099fc9f4b3b08ca3b30e65.tar.bz2
gentoo-d69b5d7550ca3a4ea7099fc9f4b3b08ca3b30e65.zip
dev-python/argcomplete: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/argcomplete/Manifest1
-rw-r--r--dev-python/argcomplete/argcomplete-3.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/argcomplete/Manifest b/dev-python/argcomplete/Manifest
index 51452ab29191..c1284b38a097 100644
--- a/dev-python/argcomplete/Manifest
+++ b/dev-python/argcomplete/Manifest
@@ -1 +1,2 @@
DIST argcomplete-3.0.8.tar.gz 56035 BLAKE2B 0b63eff175c2780b63d07ef48169054705a4af5b0e7f1097fc74e525592491d42a48615b766e32cb69a673e26d867cae84fb23b98194c9fe618409d3eb312b83 SHA512 4667f0d03485c81048c53ecfd53fa1bbe50beea15f723f3ebd8a92aae37dd2bbca709f9b6a1e0a5a682f9e769883f94614b4fcefc1fd7c9fad9f1d8cbc1429f3
+DIST argcomplete-3.1.0.tar.gz 89193 BLAKE2B de081c6c2a053835fde0e6fd446e7f310fae2e39dfd7dd0afd12c350ea6518623115f575a5b4479f466071f6c699ff336ee19dbe4ef02ae8e886ceef53cb0afc SHA512 43c28971661c1af0de9a69b05925ef83b6a8e9b007567d2e4a6344d2c1f34ee280e4306718eb6abad0883a96a2f8b4f4242f1436b0e7709944f4ec48a119e66d
diff --git a/dev-python/argcomplete/argcomplete-3.1.0.ebuild b/dev-python/argcomplete/argcomplete-3.1.0.ebuild
new file mode 100644
index 000000000000..82dbb5a4320f
--- /dev/null
+++ b/dev-python/argcomplete/argcomplete-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Bash tab completion for argparse"
+HOMEPAGE="
+ https://github.com/kislyuk/argcomplete/
+ https://pypi.org/project/argcomplete/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# pip is called as an external tool
+BDEPEND="
+ test? (
+ app-shells/fish
+ app-shells/tcsh
+ app-shells/zsh
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pip-19
+ )
+"
+
+src_prepare() {
+ sed -i -e 's:timeout=5:timeout=180:' test/test.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" test/test.py -v || die
+}