summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-18 22:18:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-18 22:34:27 -0400
commitefd68dea72969804a4b30a968e037e5ca957bf95 (patch)
tree777fbd301e2d2366918d5e59f400283dc1e47b6a /dev-qt
parentdev-qt/qtbase: skip known failing tests on BE arches (diff)
downloadgentoo-efd68dea72969804a4b30a968e037e5ca957bf95.tar.gz
gentoo-efd68dea72969804a4b30a968e037e5ca957bf95.tar.bz2
gentoo-efd68dea72969804a4b30a968e037e5ca957bf95.zip
dev-qt/qtbase: skip NaN related tests for hppa-only
May or may not have other impacts and could use fixing, but skipping noise about this for now. Assuming unlikely to come up on non-hppa, so skipping only there. Will see if other arches somehow come up. Bug: https://bugs.gentoo.org/914371 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtbase/qtbase-6.5.2-r2.ebuild5
-rw-r--r--dev-qt/qtbase/qtbase-6.5.9999.ebuild5
-rw-r--r--dev-qt/qtbase/qtbase-6.6.9999.ebuild5
-rw-r--r--dev-qt/qtbase/qtbase-6.9999.ebuild5
4 files changed, 20 insertions, 0 deletions
diff --git a/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild b/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
index 06bb9118196a..c47ffa70d566 100644
--- a/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.2-r2.ebuild
@@ -311,6 +311,11 @@ src_test() {
tst_qimagereader
tst_qimage
')
+ # fails due to hppa's NaN handling, needs looking into (bug #914371)
+ $(usev hppa '
+ tst_qcborvalue
+ tst_qnumeric
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)
diff --git a/dev-qt/qtbase/qtbase-6.5.9999.ebuild b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
index 137c9f694949..a5e477d6c8c6 100644
--- a/dev-qt/qtbase/qtbase-6.5.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.5.9999.ebuild
@@ -309,6 +309,11 @@ src_test() {
tst_qimagereader
tst_qimage
')
+ # fails due to hppa's NaN handling, needs looking into (bug #914371)
+ $(usev hppa '
+ tst_qcborvalue
+ tst_qnumeric
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)
diff --git a/dev-qt/qtbase/qtbase-6.6.9999.ebuild b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
index 58bf530a1d11..ba01c16ca68f 100644
--- a/dev-qt/qtbase/qtbase-6.6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.6.9999.ebuild
@@ -309,6 +309,11 @@ src_test() {
tst_qimagereader
tst_qimage
')
+ # fails due to hppa's NaN handling, needs looking into (bug #914371)
+ $(usev hppa '
+ tst_qcborvalue
+ tst_qnumeric
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)
diff --git a/dev-qt/qtbase/qtbase-6.9999.ebuild b/dev-qt/qtbase/qtbase-6.9999.ebuild
index becc650ea1ce..21e519807742 100644
--- a/dev-qt/qtbase/qtbase-6.9999.ebuild
+++ b/dev-qt/qtbase/qtbase-6.9999.ebuild
@@ -312,6 +312,11 @@ src_test() {
tst_qimagereader
tst_qimage
')
+ # fails due to hppa's NaN handling, needs looking into (bug #914371)
+ $(usev hppa '
+ tst_qcborvalue
+ tst_qnumeric
+ ')
# note: for linux, upstream only really runs+maintains tests for amd64
# https://doc.qt.io/qt-6/supported-platforms.html
)