summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:53:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:22 +0200
commit5ca1e6bc982dac87094284f17752981da28f31cb (patch)
tree687386b270415fbe43e8b639a714ba75b9a73e37 /dev-ros/cv_bridge
parentros-meta/vision_opencv: Bump to 1.15.0. (diff)
downloadgentoo-5ca1e6bc982dac87094284f17752981da28f31cb.tar.gz
gentoo-5ca1e6bc982dac87094284f17752981da28f31cb.tar.bz2
gentoo-5ca1e6bc982dac87094284f17752981da28f31cb.zip
dev-ros/cv_bridge: update patch
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/cv_bridge')
-rw-r--r--dev-ros/cv_bridge/files/boostpython.patch11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-ros/cv_bridge/files/boostpython.patch b/dev-ros/cv_bridge/files/boostpython.patch
index 72fac8087363..a6192f98be24 100644
--- a/dev-ros/cv_bridge/files/boostpython.patch
+++ b/dev-ros/cv_bridge/files/boostpython.patch
@@ -2,14 +2,17 @@ Index: cv_bridge/CMakeLists.txt
===================================================================
--- cv_bridge.orig/CMakeLists.txt
+++ cv_bridge/CMakeLists.txt
-@@ -5,11 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
+@@ -5,14 +5,7 @@ find_package(catkin REQUIRED COMPONENTS
if(NOT ANDROID)
find_package(PythonLibs)
-- if(PYTHONLIBS_VERSION_STRING VERSION_LESS 3)
-- find_package(Boost REQUIRED python)
+-
+- if(PYTHONLIBS_VERSION_STRING VERSION_LESS "3.8")
+- # Debian Buster
+- find_package(Boost REQUIRED python37)
- else()
-- find_package(Boost REQUIRED python3)
+- # Ubuntu Focal
+- find_package(Boost REQUIRED python)
- endif()
+ find_package(Boost REQUIRED python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
else()