summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-25 09:59:48 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-25 10:54:51 +0100
commitddf24dcabdde79d20f24be33ccd71d01c07f2b51 (patch)
tree29908900754c380e572a6410dbf6ab028a944964 /dev-ros/rosservice/rosservice-1.13.0.ebuild
parentdev-ros/rosparam: Bump to 1.13.0. (diff)
downloadgentoo-ddf24dcabdde79d20f24be33ccd71d01c07f2b51.tar.gz
gentoo-ddf24dcabdde79d20f24be33ccd71d01c07f2b51.tar.bz2
gentoo-ddf24dcabdde79d20f24be33ccd71d01c07f2b51.zip
dev-ros/rosservice: Bump to 1.13.0.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rosservice/rosservice-1.13.0.ebuild')
-rw-r--r--dev-ros/rosservice/rosservice-1.13.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosservice/rosservice-1.13.0.ebuild b/dev-ros/rosservice/rosservice-1.13.0.ebuild
new file mode 100644
index 000000000000..af33c40de4dd
--- /dev/null
+++ b/dev-ros/rosservice/rosservice-1.13.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for listing and querying ROS Services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosmsg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"