summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 11:50:37 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commit5a146bb8621d440198ea59245c8c7082a200c5f1 (patch)
tree54f972157491f6b461518b6663b2e890884e64ba /dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild
parentdev-ros/rospy: Bump to 1.11.17. (diff)
downloadgentoo-5a146bb8621d440198ea59245c8c7082a200c5f1.tar.gz
gentoo-5a146bb8621d440198ea59245c8c7082a200c5f1.tar.bz2
gentoo-5a146bb8621d440198ea59245c8c7082a200c5f1.zip
dev-ros/test_rosbag: Bump to 1.11.17.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild')
-rw-r--r--dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild b/dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild
new file mode 100644
index 000000000000..fd134828883f
--- /dev/null
+++ b/dev-ros/test_rosbag/test_rosbag-1.11.17.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for rosbag"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_generation
+ dev-ros/rosbag[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/topic_tools[${PYTHON_USEDEP}]
+ dev-ros/xmlrpcpp
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/boost[threads]
+ app-arch/bzip2
+ dev-ros/rosout
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-cpp/gtest
+ )
+"