summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-08-22 09:41:10 +0200
committerHans de Graaff <graaff@gentoo.org>2020-08-22 09:55:53 +0200
commitf8b01cf1c2aecc4d6fe025b5888533d7df4d4719 (patch)
treef86ba6529425cf4b9493dfc47d881ad4b1531010 /dev-ruby/colorize
parentdev-ruby/columnize: add ruby27 (diff)
downloadgentoo-f8b01cf1c2aecc4d6fe025b5888533d7df4d4719.tar.gz
gentoo-f8b01cf1c2aecc4d6fe025b5888533d7df4d4719.tar.bz2
gentoo-f8b01cf1c2aecc4d6fe025b5888533d7df4d4719.zip
dev-ruby/colorize: add ruby27
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/colorize')
-rw-r--r--dev-ruby/colorize/colorize-0.8.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/colorize/colorize-0.8.1-r1.ebuild b/dev-ruby/colorize/colorize-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..69919f193d55
--- /dev/null
+++ b/dev-ruby/colorize/colorize-0.8.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set color, background color and text effect on console easier"
+HOMEPAGE="https://github.com/fazibear/colorize"
+LICENSE="GPL-2+"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Cc]ode[Cc]limate/d" test/test_colorize.rb || die
+}
+
+each_ruby_test() {
+ cd test || die
+ ${RUBY} test_colorize.rb || die
+}