summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-27 08:11:04 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-27 09:13:12 +0200
commit2f6ed8a5fc842a74e5d00e1b3dcd65b5f5dc1c40 (patch)
tree556659044a3507fc5d935d14a27504ff34c84b35 /dev-ruby/date
parentdev-ruby/net-protocol: enable ruby31 (diff)
downloadgentoo-2f6ed8a5fc842a74e5d00e1b3dcd65b5f5dc1c40.tar.gz
gentoo-2f6ed8a5fc842a74e5d00e1b3dcd65b5f5dc1c40.tar.bz2
gentoo-2f6ed8a5fc842a74e5d00e1b3dcd65b5f5dc1c40.zip
dev-ruby/date: initial import of 3.2.2
Extraced from dev-lang/ruby, keywords set accordingly. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/date')
-rw-r--r--dev-ruby/date/Manifest1
-rw-r--r--dev-ruby/date/date-3.2.2.ebuild32
-rw-r--r--dev-ruby/date/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/date/Manifest b/dev-ruby/date/Manifest
new file mode 100644
index 000000000000..8baef840e9d3
--- /dev/null
+++ b/dev-ruby/date/Manifest
@@ -0,0 +1 @@
+DIST date-3.2.2.tar.gz 108973 BLAKE2B aedb4d5d43b1d7ac277bc6fd36651f36828be7a04f4eb75c45ea02bc56b3a403af9e8a26b23a9839c904ae455e6a02476fe83115d8c816f06168db6e0a788347 SHA512 5a640b550c9ea0c1fa24aa5d114ae9108fd568c8c38b20434168a92c886d66487065e0c6aedc7e55cbe59cc3338fd262ca601267ed0b55377c382fe0502e9604
diff --git a/dev-ruby/date/date-3.2.2.ebuild b/dev-ruby/date/date-3.2.2.ebuild
new file mode 100644
index 000000000000..49bab8d1e38f
--- /dev/null
+++ b/dev-ruby/date/date-3.2.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/date/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="date.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A subclass of Object includes Comparable module for handling dates"
+HOMEPAGE="https://github.com/ruby/date"
+SRC_URI="https://github.com/ruby/date/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/date/metadata.xml b/dev-ruby/date/metadata.xml
new file mode 100644
index 000000000000..5f05b08cb0a8
--- /dev/null
+++ b/dev-ruby/date/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/date</remote-id>
+ </upstream>
+</pkgmetadata>