summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-08-12 08:50:23 +0200
committerHans de Graaff <graaff@gentoo.org>2023-08-12 09:21:26 +0200
commit930159a5b73991d34dfe4bda5256670cdd1c9e89 (patch)
treebfe03a4e46b98156af055583113bfb7151f41b76 /dev-ruby/rack-protection
parentdev-ruby/rss: add 0.3.0 (diff)
downloadgentoo-930159a5b73991d34dfe4bda5256670cdd1c9e89.tar.gz
gentoo-930159a5b73991d34dfe4bda5256670cdd1c9e89.tar.bz2
gentoo-930159a5b73991d34dfe4bda5256670cdd1c9e89.zip
dev-ruby/rack-protection: add 3.1.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-3.1.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index 563cbdc9d1cb..dc9a78f21d51 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1,3 +1,4 @@
DIST rack-protection-2.2.3.gem 17920 BLAKE2B 7a66cf4d5de68acd3ef4c7db2485657ce226e3101660f4f15bb3a8ab937785211055e49d676cf73cf52d4896e787d8f78a62099549a4ff846b5963c4247b5dd3 SHA512 ce41e1e61016090125557d8211b65b0fc9d545fac6c42f64fb3f48ac0fea56689e17acf7aca6cd82137ba7384c559ac47ac9995f57068f3f216ae61b7fe8953d
DIST rack-protection-3.0.5.gem 20480 BLAKE2B 1fa11760c6ddac58234ffe2e6d783c985e29b5e2bd10ea21b0782f7824b5930351c8e32c9401b6276ef028adcd8b25ca4458333d8008a554c413f54315ff8809 SHA512 4ed0ee9e8fe08532ff7f2905251af110f3fff0e419da5be50ae3e5a90906e43c39cf8edc219fcfe3e27a72591500c040afcc9552da875773375b170fb91aa9ff
DIST rack-protection-3.0.6.gem 20480 BLAKE2B b29d8b87dd7bc4629d97923a448feacb53ae62f8d3753b44a627db742e3065eb1d09846e0be9131b02c83a32e1241154a844fcd5a5a7e708039cae7f6938fbb8 SHA512 4763a0439a3d99cfd799325004c7e6cb46783b3fcd77ea0df08caa6b5cdfc95c6ec96791d79261a0d7df26eb0b084e7ead2cceb05b589617159e948b3172e564
+DIST rack-protection-3.1.0.gem 20480 BLAKE2B ae5a784eb7420b756d15b251ebc981197f11979e76fed2ad42eb0bcf84719f4b9ab9d68a40ac9ee8db392ad7a8c45c8d4f03de2efb0375dbaa131ec5ff2022e2 SHA512 18a5ffe614a906ca876926bff3e4d1657f0b6963005ee32de80d0ab987b9465f603b30d69f07fd8d8a1ebf4fa85eb89bfd0b607d72387b360d13bea113a63ef7
diff --git a/dev-ruby/rack-protection/rack-protection-3.1.0.ebuild b/dev-ruby/rack-protection/rack-protection-3.1.0.ebuild
new file mode 100644
index 000000000000..d1d2be4d588d
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-3.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://sinatrarb.com/protection/"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"