summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-21 10:54:32 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-21 10:54:32 +0200
commit94056a41b38e6eb3c1b8f694eb03b6c48cab70ed (patch)
tree70b3c34e8a5f367be83e73b2ef1603d864f647a8 /dev-ruby/tidy-ext
parentdev-ruby/sigar: treeclean (diff)
downloadgentoo-94056a41b38e6eb3c1b8f694eb03b6c48cab70ed.tar.gz
gentoo-94056a41b38e6eb3c1b8f694eb03b6c48cab70ed.tar.bz2
gentoo-94056a41b38e6eb3c1b8f694eb03b6c48cab70ed.zip
dev-ruby/tidy-ext: treeclean
Closes: https://bugs.gentoo.org/587222 Closes: https://bugs.gentoo.org/884409 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-ruby/tidy-ext')
-rw-r--r--dev-ruby/tidy-ext/Manifest1
-rw-r--r--dev-ruby/tidy-ext/files/11CVE-2015-5522.patch34
-rw-r--r--dev-ruby/tidy-ext/metadata.xml11
-rw-r--r--dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild34
4 files changed, 0 insertions, 80 deletions
diff --git a/dev-ruby/tidy-ext/Manifest b/dev-ruby/tidy-ext/Manifest
deleted file mode 100644
index adca93b6a591..000000000000
--- a/dev-ruby/tidy-ext/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST tidy-ext-0.1.14.gem 260608 BLAKE2B 5401ec2019f25307f4083f3a1717cd2b0419e0025875b0ad461c72e50445f9b1ffc488a723db04432d262cf2dd94fd267f5261b33eb53d829f4a03d5cd29ab30 SHA512 8a8eada3cb5e815338de49332a24c85b9b2cabba0e10f2d72fe85bd4faf76924e52d82066e7b73e62bc459631aaa9d1c42a6941988ae2a71ca0ddd4f3302ad86
diff --git a/dev-ruby/tidy-ext/files/11CVE-2015-5522.patch b/dev-ruby/tidy-ext/files/11CVE-2015-5522.patch
deleted file mode 100644
index 942209873be0..000000000000
--- a/dev-ruby/tidy-ext/files/11CVE-2015-5522.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From c18f27a58792f7fbd0b30a0ff50d6b40a82f940d Mon Sep 17 00:00:00 2001
-From: Geoff McLane <ubuntu@geoffair.info>
-Date: Wed, 3 Jun 2015 20:26:03 +0200
-Subject: [PATCH] Issue #217 - avoid len going negative, ever...
-
----
- src/lexer.c | 8 +++++---
- 1 file changed, 5 insertions(+), 3 deletions(-)
-
-diff --git a/src/lexer.c b/src/lexer.c
-index 376a3d8..664f806 100644
---- a/ext/tidy/lexer.c
-+++ b/ext/tidy/lexer.c
-@@ -3739,16 +3740,17 @@ static tmbstr ParseValue( TidyDocImpl* doc, ctmbstr name,
- /* and prompts attributes unless --literal-attributes is set to yes */
- /* #994841 - Whitespace is removed from value attributes */
-
-- if (munge &&
-+ /* Issue #217 - Also only if/while (len > 0) - MUST NEVER GO NEGATIVE! */
-+ if ((len > 0) && munge &&
- TY_(tmbstrcasecmp)(name, "alt") &&
- TY_(tmbstrcasecmp)(name, "title") &&
- TY_(tmbstrcasecmp)(name, "value") &&
- TY_(tmbstrcasecmp)(name, "prompt"))
- {
-- while (TY_(IsWhite)(lexer->lexbuf[start+len-1]))
-+ while (TY_(IsWhite)(lexer->lexbuf[start+len-1]) && (len > 0))
- --len;
-
-- while (TY_(IsWhite)(lexer->lexbuf[start]) && start < len)
-+ while (TY_(IsWhite)(lexer->lexbuf[start]) && (start < len) && (len > 0))
- {
- ++start;
- --len;
diff --git a/dev-ruby/tidy-ext/metadata.xml b/dev-ruby/tidy-ext/metadata.xml
deleted file mode 100644
index 0432a268b965..000000000000
--- a/dev-ruby/tidy-ext/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>ruby@gentoo.org</email>
- <name>Gentoo Ruby Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">carld/tidy</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild b/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
deleted file mode 100644
index 1027b579d387..000000000000
--- a/dev-ruby/tidy-ext/tidy-ext-0.1.14-r4.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTENSIONS=(ext/tidy/extconf.rb)
-
-inherit ruby-fakegem
-
-DESCRIPTION="W3C HTML Tidy library implemented as a Ruby extension"
-HOMEPAGE="https://github.com/carld/tidy"
-
-LICENSE="HTML-Tidy"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ppc ppc64 ~sparc x86"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/11CVE-2015-5522.patch" )
-
-all_ruby_prepare() {
- mkdir lib || die
-
- # Remove reference to rspec 1
- sed -i -e '/spec/d' spec/spec_helper.rb || die
-
- # Avoid spec that needs network connectivity.
- rm spec/tidy/remote_uri_spec.rb || die
-
- # rspec 3 compatibility
- sed -i -e 's/be_true/be_truthy/' spec/tidy/compat_spec.rb || die
-}