summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-13 10:58:39 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-13 11:20:48 +0200
commit793e1b90ea0042302376cc44717059a3402f1853 (patch)
tree5110bd3a635805d04f650541f9e5ed3638789cb4 /dev-ruby/unindent/unindent-1.0-r1.ebuild
parentdev-ruby/nanotest: add ruby30; EAPI 7 (diff)
downloadgentoo-793e1b90ea0042302376cc44717059a3402f1853.tar.gz
gentoo-793e1b90ea0042302376cc44717059a3402f1853.tar.bz2
gentoo-793e1b90ea0042302376cc44717059a3402f1853.zip
dev-ruby/unindent: add ruby30; EAPI 7
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/unindent/unindent-1.0-r1.ebuild')
-rw-r--r--dev-ruby/unindent/unindent-1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ruby/unindent/unindent-1.0-r1.ebuild b/dev-ruby/unindent/unindent-1.0-r1.ebuild
new file mode 100644
index 000000000000..5c81007c698f
--- /dev/null
+++ b/dev-ruby/unindent/unindent-1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby method to unindent strings"
+HOMEPAGE="https://github.com/mynyml/unindent"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/nanotest )"
+
+each_ruby_test() {
+ ${RUBY} -I.:lib test/test_unindent.rb || die
+}