summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-17 07:24:19 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-17 07:46:24 +0100
commit6a2a7cadfb705c2dca9793189fbf0dc6dfefbd6b (patch)
tree6637aea04afeecb1a491f4e8d29eaa02ba791f57 /dev-ruby
parentdev-ruby/nokogiri: drop 1.15.4, 1.16.0, 1.16.1 (diff)
downloadgentoo-6a2a7cadfb705c2dca9793189fbf0dc6dfefbd6b.tar.gz
gentoo-6a2a7cadfb705c2dca9793189fbf0dc6dfefbd6b.tar.bz2
gentoo-6a2a7cadfb705c2dca9793189fbf0dc6dfefbd6b.zip
dev-ruby/term-ansicolor: add 1.7.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/term-ansicolor/Manifest1
-rw-r--r--dev-ruby/term-ansicolor/term-ansicolor-1.7.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/term-ansicolor/Manifest b/dev-ruby/term-ansicolor/Manifest
index b8c1f9c3f191..48a45f3c5d3c 100644
--- a/dev-ruby/term-ansicolor/Manifest
+++ b/dev-ruby/term-ansicolor/Manifest
@@ -1 +1,2 @@
DIST term-ansicolor-1.7.1.gem 44544 BLAKE2B 2c2c2de0a18d1f9a975901f8a7005f740ac81a609c43705d8c184deb26dc9010876deeca411488c787132a3d8b78339c75b0776f3c9bba1ff71efa23ce3671a6 SHA512 d49f8825c31accfaa58a2f34ed5fbdaf503d4b47c23f07c52cc82bbf6cce457bd9371e197da1ec36dc83e32b95e9ea9a349922d9759a827923456ea46f81ff50
+DIST term-ansicolor-1.7.2.gem 44544 BLAKE2B 46ec73afb7f9862960a68feee4664babc2bd3597aa48dd59712c9f48d3e6d1a0a2a1bc0e6ecfdbd196a97f79d66460535f6fb6ca347edfffed52187eebf79b15 SHA512 e81fc32f07d5f85eb0f364069afb143f87dea9fab6c6dd03bba95cdcc74495cdfb87ee334f595c8636226e50801274191a083eee5b70c3e8289d04cc49a1acb6
diff --git a/dev-ruby/term-ansicolor/term-ansicolor-1.7.2.ebuild b/dev-ruby/term-ansicolor/term-ansicolor-1.7.2.ebuild
new file mode 100644
index 000000000000..8ad8e826fd29
--- /dev/null
+++ b/dev-ruby/term-ansicolor/term-ansicolor-1.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_GEMSPEC="term-ansicolor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Small Ruby library that colors strings using ANSI escape sequences"
+HOMEPAGE="https://flori.github.io/term-ansicolor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_rdepend ">=dev-ruby/tins-1.0"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:tests -e 'Dir["tests/*_test.rb"].each{|f| require f}' || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}