summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 09:48:19 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-08-17 09:48:58 +0200
commit269c18e3b4dc23d0c9df99e9f3971a0dc51d2b40 (patch)
tree8b356837dc3a780ea03a7955c3c97db75987bd39 /dev-util/cookiecutter
parentmedia-libs/oneVPL-intel-gpu: add 23.3.0 (diff)
downloadgentoo-269c18e3b4dc23d0c9df99e9f3971a0dc51d2b40.tar.gz
gentoo-269c18e3b4dc23d0c9df99e9f3971a0dc51d2b40.tar.bz2
gentoo-269c18e3b4dc23d0c9df99e9f3971a0dc51d2b40.zip
dev-util/cookiecutter: add 2.3.0
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-util/cookiecutter')
-rw-r--r--dev-util/cookiecutter/Manifest1
-rw-r--r--dev-util/cookiecutter/cookiecutter-2.3.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-util/cookiecutter/Manifest b/dev-util/cookiecutter/Manifest
index fdac6abec73d..c6ead6ce4a68 100644
--- a/dev-util/cookiecutter/Manifest
+++ b/dev-util/cookiecutter/Manifest
@@ -1,2 +1,3 @@
DIST cookiecutter-2.1.1.tar.gz 263100 BLAKE2B 6f054cc5e03328db3198443fe1f99bbef285fe03a1f9bf588b4b80d2314da10f6c998221cf6c41bff9c7fdc3c92680290468dfb070ade4a868ab80f941c1f6a4 SHA512 7833bfc0e6d2d32060e099a97a4477114c2e6f9b09f951c4a5519153fd7c1f9659c22596e443392272f4a6f80eabb2a346417bac56ea7ea4108fc6b36fc0072c
DIST cookiecutter-2.2.3.tar.gz 271925 BLAKE2B 01c981b2650f6b4a962e231b5642fe99d8456e000d4ffc83be67df4c092d7192851cfdeb8d157d5c2db481346e4abf9671b9d80b24b17b0cc56cd9238ef11e6c SHA512 40df677c27c0b226cca36ecb983bd3b3e17b5aa0aac39df390064fdd54397971d3d8f2e2242c78459573bd9e49cdee0d42370cf65a6f752e6f372905b05baadb
+DIST cookiecutter-2.3.0.tar.gz 273048 BLAKE2B 9515ae58271c61a040b176fbede49bed198343a51a136509933ced4712252f359a1027e9fe5797a1ab0e37cdaaa962ad4a65927ddfd4514641f87bfb9507e566 SHA512 f1930ce79781119ea12e18dd1dfb05777989bc121a3292294314f4320e124ac62945120f85c7a720b6bd475acb07b162fb247486855e6180449eb50c8c5ee93c
diff --git a/dev-util/cookiecutter/cookiecutter-2.3.0.ebuild b/dev-util/cookiecutter/cookiecutter-2.3.0.ebuild
new file mode 100644
index 000000000000..a87e03b56fbb
--- /dev/null
+++ b/dev-util/cookiecutter/cookiecutter-2.3.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Command-line utility to create projects from cookiecutters (project templates)"
+HOMEPAGE="https://github.com/cookiecutter/cookiecutter"
+SRC_URI="https://github.com/cookiecutter/cookiecutter/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/arrow[${PYTHON_USEDEP}]
+ >=dev-python/binaryornot-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ <dev-python/jinja-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.23.0[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+DOCS=( README.md HISTORY.md CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}/test_cli-1.7.2.patch"
+)
+
+distutils_enable_tests pytest
+# TODO: Package sphinx-click
+# distutils_enable_sphinx docs \
+# dev-python/sphinx-rtd-theme \
+# dev-python/recommonmark
+
+python_test() {
+ epytest -o addopts=
+}