summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-20 20:11:12 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2020-08-20 20:11:29 -0700
commit820d1bcd4203fb50a4b83e8a368537798c3096e2 (patch)
treefa26d8931949bf970b9a91cf0444b7eeec90b577 /dev-util/google-perftools
parentdev-util/google-perftools: bump to 2.8 (diff)
downloadgentoo-820d1bcd4203fb50a4b83e8a368537798c3096e2.tar.gz
gentoo-820d1bcd4203fb50a4b83e8a368537798c3096e2.tar.bz2
gentoo-820d1bcd4203fb50a4b83e8a368537798c3096e2.zip
dev-util/google-perftools: drop old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/google-perftools')
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.6.2.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 766db525c2aa..8fdcb2326bee 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,3 +1,2 @@
-DIST gperftools-2.6.2.tar.gz 911811 BLAKE2B 1201185f3008f75b9db219e47658f5b34294f15d5cae5a9badbc2718d63e58c07e485e84f6af05bdd12398c7ab8af520db9f34f4b33b790b0276ba10fb945358 SHA512 2630687d98cdb7011b9b90ba65e337d74f7e1f7d44190edf5414d0898b906686e547e4bb08979f26fb16ca1ccc065a5a1022dee03539bb1ccdf136439eb99ec1
DIST gperftools-2.7.tar.gz 916854 BLAKE2B d14c2b88f2986d3691d7184e1759de2066ca50224f745a6291ab2ebd5f7f985dec4916a1c01d61142eca9b64f3742c50b82e64118602afaa7b27ae2d94a4ed4d SHA512 4a8e72b960218b0615281b830b3f1a4a1b27830006c45ed68b1ffd152bb50a8b3beec850526e330e2ad08c28774bdc01dade9bcc3e7c9e26d30823cc55648d77
DIST gperftools-2.8.tar.gz 928379 BLAKE2B e94bac4153cb5d3170d6486a9065b56d631ab261d25b4a5a150f04f87f767c203508839daf400dbe06dc82e9e3da2988e4b4c74725c6be836fa9c70ed0576209 SHA512 c959ffa2b36ecfea10927b40b6dd668385cff7eab3c4bc2d7c5aed5f4de87ce8e4f9b30ab44652a0288badbb6c5aa7110c491b13c4030fb656609c2eb25918a8
diff --git a/dev-util/google-perftools/google-perftools-2.6.2.ebuild b/dev-util/google-perftools/google-perftools-2.6.2.ebuild
deleted file mode 100644
index 9d0679575689..000000000000
--- a/dev-util/google-perftools/google-perftools-2.6.2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P="gperftools-${PV}"
-inherit toolchain-funcs flag-o-matic vcs-snapshot autotools multilib-minimal
-
-DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
-HOMEPAGE="https://github.com/gperftools/gperftools"
-SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/4"
-# contains ASM code, with support for
-# freebsd x86/amd64
-# linux x86/amd64/ppc/ppc64/arm
-# OSX ppc/amd64
-# AIX ppc/ppc64
-KEYWORDS="-* amd64 arm ~arm64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="largepages +debug minimal optimisememory test static-libs"
-RESTRICT="!test? ( test )"
-
-DEPEND="sys-libs/libunwind"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-HTML_DOCS="docs"
-
-pkg_setup() {
- # set up the make options in here so that we can actually make use
- # of them on both compile and install.
-
- # Avoid building the unit testing if we're not going to execute
- # tests; this trick here allows us to ignore the tests without
- # touching the build system (and thus without rebuilding
- # autotools). Keep commented as long as it's restricted.
- use test || \
- MAKEOPTS+=" noinst_PROGRAMS= "
-}
-
-src_prepare() {
- default
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- use largepages && append-cppflags -DTCMALLOC_LARGE_PAGES
- use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
- append-flags -fno-strict-aliasing -fno-omit-frame-pointer
-
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug debugalloc) \
- $(if [[ ${ABI} == x32 ]]; then printf "--enable-minimal\n" else use_enable minimal; fi)
-}
-
-src_test() {
- case "${LD_PRELOAD}" in
- *libsandbox*)
- ewarn "Unable to run tests when sandbox is enabled."
- ewarn "See https://bugs.gentoo.org/290249"
- return 0
- ;;
- esac
-
- multilib-minimal_src_test
-}
-
-src_install() {
- if ! use minimal && has x32 ${MULTILIB_ABIS}; then
- MULTILIB_WRAPPED_HEADERS=(
- /usr/include/gperftools/heap-checker.h
- /usr/include/gperftools/heap-profiler.h
- /usr/include/gperftools/stacktrace.h
- /usr/include/gperftools/profiler.h
- )
- fi
-
- multilib-minimal_src_install
-}