summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-09-20 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-09-21 12:05:36 -0400
commit5eba1ad19f198fd452a4c3ccd8570b50328c8bae (patch)
treee40b76650d0ac678f9582b4b6dceb390a68ed714 /dev-util/gyp
parentdev-python/aiohttp-socks: Bump to 0.5.4 (diff)
downloadgentoo-5eba1ad19f198fd452a4c3ccd8570b50328c8bae.tar.gz
gentoo-5eba1ad19f198fd452a4c3ccd8570b50328c8bae.tar.bz2
gentoo-5eba1ad19f198fd452a4c3ccd8570b50328c8bae.zip
dev-util/gyp: Version bump (20200512145953).
Bug: https://bugs.gentoo.org/695000 Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util/gyp')
-rw-r--r--dev-util/gyp/Manifest1
-rw-r--r--dev-util/gyp/gyp-20200512145953.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/gyp/Manifest b/dev-util/gyp/Manifest
index a8345477155d..154c7d858629 100644
--- a/dev-util/gyp/Manifest
+++ b/dev-util/gyp/Manifest
@@ -1 +1,2 @@
DIST gyp-20170904022846.tar.xz 447608 BLAKE2B 41f0e28d04039358a9e4ec9628fe1d936d19748061ea882a4e47f2cb23549db3866c5281e102b8f95d6ed37cfe999e7342129a81333671ee42534fc53d2a0d0e SHA512 9336be1103048fe5f51f90fcb2a153bba7638e71e4b579c47b725db81ae4257a56a8f7dacddc936e627862ee6149a453f1c7f5bede633cbd3076e0fa2fce07a7
+DIST gyp-20200512145953.tar.xz 443884 BLAKE2B 74ff269e3e8aa51e6b34f795892f6e8922d098a81b4d855619520d3d366e79b611931cddf4ee2ec60a7e040af11ac8eba7582ad10e24de627df5a4aa4eba6474 SHA512 35bf2af22f2e632b3d6e546e5017df8effd0c7ad80beed9b95ed1e2f294d70215889bc6a0147506461254e951d70189dc48824af10a6620e996945d2cf5586ee
diff --git a/dev-util/gyp/gyp-20200512145953.ebuild b/dev-util/gyp/gyp-20200512145953.ebuild
new file mode 100644
index 000000000000..95e9e43a2eed
--- /dev/null
+++ b/dev-util/gyp/gyp-20200512145953.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2017-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=(python{3_6,3_7})
+DISTUTILS_SINGLE_IMPL="1"
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+
+inherit distutils-r1
+
+if [[ "${PV}" == "99999999999999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://chromium.googlesource.com/external/gyp"
+fi
+
+DESCRIPTION="GYP (Generate Your Projects) meta-build system"
+HOMEPAGE="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
+if [[ "${PV}" == "99999999999999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://home.apache.org/~arfrever/distfiles/${P}.tar.xz"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=""
+DEPEND=""
+RDEPEND=""
+
+python_test() {
+ # More errors with DeprecationWarnings enabled.
+ local -x PYTHONWARNINGS=""
+
+ "${PYTHON}" gyptest.py --all --verbose
+}