summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElizabeth Myers <elizabeth@interlinked.me>2015-12-08 06:18:21 -0600
committerElizabeth Myers <elizabeth@interlinked.me>2015-12-08 06:18:21 -0600
commit2448451a194e0473c88d114328584bd08ca218cf (patch)
tree01fc820b244aea54ed12ad3e3ba593187f8c0241 /dev-util/pkgconf/pkgconf-0.9.12.ebuild
parentsys-process/criu: version bump to 1.8 (diff)
downloadgentoo-2448451a194e0473c88d114328584bd08ca218cf.tar.gz
gentoo-2448451a194e0473c88d114328584bd08ca218cf.tar.bz2
gentoo-2448451a194e0473c88d114328584bd08ca218cf.zip
dev-util/pkgconf: bump to version 0.9.12.
This version fixes some deduplication edge cases on -L and -I CFLAGS/LIBS.
Diffstat (limited to 'dev-util/pkgconf/pkgconf-0.9.12.ebuild')
-rw-r--r--dev-util/pkgconf/pkgconf-0.9.12.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/pkgconf/pkgconf-0.9.12.ebuild b/dev-util/pkgconf/pkgconf-0.9.12.ebuild
new file mode 100644
index 000000000000..7ee43dedb5d2
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.9.12.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2 multilib-minimal
+else
+ inherit eutils multilib-minimal
+ SRC_URI="http://rabbit.dereferenced.org/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+RESTRICT="test" # at least until 0.9.13
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/pkgconf
+)
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+
+ if use pkg-config; then
+ MULTILIB_CHOST_TOOLS+=(
+ /usr/bin/pkg-config
+ )
+ fi
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf $(use_enable strict)
+}
+
+multilib_src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}