summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-05-30 11:20:11 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-05-30 11:52:06 -0400
commit45c54345133147897f4ec949343b15a395d31e08 (patch)
treef1467845afe4297a850a84e9ad873784dd33ed5f /dev-util/qbs
parentsci-physics/geant4_vmc: add missing sci-physics/vgm USE deps (diff)
downloadgentoo-45c54345133147897f4ec949343b15a395d31e08.tar.gz
gentoo-45c54345133147897f4ec949343b15a395d31e08.tar.bz2
gentoo-45c54345133147897f4ec949343b15a395d31e08.zip
dev-util/qbs: add workaround for gcc:14 + -O3 build failure
Exact cause unknown, but no harm in doing this for now. Does not seem needed for neither gcc:13 nor clang. For anyone trying to reproduce, don't forget to drop this. Bug: https://bugs.gentoo.org/933187 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/qbs')
-rw-r--r--dev-util/qbs/qbs-2.3.1.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-util/qbs/qbs-2.3.1.ebuild b/dev-util/qbs/qbs-2.3.1.ebuild
index 2e99070c6c0f..1eaaf83d9393 100644
--- a/dev-util/qbs/qbs-2.3.1.ebuild
+++ b/dev-util/qbs/qbs-2.3.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..13} )
-inherit cmake flag-o-matic python-any-r1
+inherit cmake flag-o-matic python-any-r1 toolchain-funcs
DESCRIPTION="Modern build tool for software projects"
HOMEPAGE="https://doc.qt.io/qbs/"
@@ -62,6 +62,10 @@ src_configure() {
# needs fixing in qtbase as *64 usage comes from its headers' macros
use elibc_musl && append-lfs-flags
+ # fails to build with gcc:14 and -O3 (bug #933187)
+ tc-is-gcc && [[ $(gcc-major-version) -ge 14 ]] &&
+ replace-flags -O3 -O2
+
local mycmakeargs=(
-DQBS_DOC_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
-DQBS_INSTALL_HTML_DOCS=$(usex doc)