summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-29 09:41:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-03-29 10:33:45 +0200
commit5170ffe3251d815bf3d8fd730fa72f59f33978c8 (patch)
tree9f57168dc6cacebb8753b7f842845fca0d028b89 /dev-util/stripe-mock
parentdev-java/batik: Bump to 1.14 (diff)
downloadgentoo-5170ffe3251d815bf3d8fd730fa72f59f33978c8.tar.gz
gentoo-5170ffe3251d815bf3d8fd730fa72f59f33978c8.tar.bz2
gentoo-5170ffe3251d815bf3d8fd730fa72f59f33978c8.zip
dev-util/stripe-mock: Bump to 0.121.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/stripe-mock')
-rw-r--r--dev-util/stripe-mock/Manifest1
-rw-r--r--dev-util/stripe-mock/stripe-mock-0.121.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/stripe-mock/Manifest b/dev-util/stripe-mock/Manifest
index 32daee41833c..956cc9222f9c 100644
--- a/dev-util/stripe-mock/Manifest
+++ b/dev-util/stripe-mock/Manifest
@@ -1,2 +1,3 @@
DIST stripe-mock-0.118.0.tar.gz 651234 BLAKE2B b6651dda1ee23ce0143688458fc695f4f3fbaf8a8320228599033e0907bac611de2cc3dfd9845f3c27b5a1a07864ca6aa744d11029b078c25b73fd0a8cf99cb5 SHA512 3fa18acd747bee7e17f8ddbe02dda0dc38b9d2fe332d3606e44a3ad75b9acb5b34bd04aace875b4c1b67e172656d7032def6dd08b364939cf76e58a5cc736015
DIST stripe-mock-0.119.0.tar.gz 659745 BLAKE2B 6db7f4006130388794e0398cc8ea1f38bd24544a2a7a520b7959b4f183a922d904742a774e18fa3da1f595687016e927864cd38334feb4c955fa70693920e8c4 SHA512 e6c38aecd8ff2f8e0dee3605b2590c42c0e4f2e101cdb4a3eee2cece0577266cec16626045a63684b98b8c20984a794c9235378713f7310123578e2773e96cf7
+DIST stripe-mock-0.121.0.tar.gz 672044 BLAKE2B 72256620a6e7507c041aba79b32bb06329bbd6250fe878da516f1abcb9dbd7ff5205fdc468882ac2331d006f3b92d6bd7683061ace8b0556c6c6898ee936f93f SHA512 680b7abcee0004b08798a79682256feb4d906b62fff6108f556e245207b92ce0fca2e1d9f38f69da06ea6677896692b2e56a24ddbcc189e7b86b89844e3d21b2
diff --git a/dev-util/stripe-mock/stripe-mock-0.121.0.ebuild b/dev-util/stripe-mock/stripe-mock-0.121.0.ebuild
new file mode 100644
index 000000000000..586567a061dc
--- /dev/null
+++ b/dev-util/stripe-mock/stripe-mock-0.121.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Mock HTTP server that responds like the real Stripe API"
+HOMEPAGE="https://github.com/stripe/stripe-mock"
+SRC_URI="https://github.com/stripe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT ISC BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ emake build
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin stripe-mock
+ einstalldocs
+}