summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2017-12-30 14:06:51 +0300
committerPatrice Clement <monsieurp@gentoo.org>2018-01-08 17:35:31 +0100
commit436a9b838828350746be74a6b08cf056141c88c7 (patch)
treeaf4f825004ba3986cc92d515dbc56688d549b006 /dev-util
parentdev-python/ansicolor: add Python 3.6 support (diff)
downloadgentoo-436a9b838828350746be74a6b08cf056141c88c7.tar.gz
gentoo-436a9b838828350746be74a6b08cf056141c88c7.tar.bz2
gentoo-436a9b838828350746be74a6b08cf056141c88c7.zip
dev-util/vint: verbump to 0.3.17
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/vint/Manifest1
-rw-r--r--dev-util/vint/vint-0.3.17.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/vint/Manifest b/dev-util/vint/Manifest
index 51d1b33cf10d..007d41de8a11 100644
--- a/dev-util/vint/Manifest
+++ b/dev-util/vint/Manifest
@@ -1,2 +1,3 @@
DIST vint-0.3.13.tar.gz 91599 BLAKE2B 7cc9a6aca8cbd259d3ff79659c38e3d51b5f0ba75a7485872fd922543d75867fcc1689b0f7f8915e3195905b47bb0a467d9646bcb29082e9c04a1557e19b3717 SHA512 ef0b811df0250899e23e30ee4b240cf8b54e510231353ca86202661fd5f0826b9faeacc9268849e51bd6a1c71c1514498dec04a7a4ed79f00a5098811525e3d4
DIST vint-0.3.16.tar.gz 94562 BLAKE2B 626c15cfa995df108b9ca085bbea9a81de6092bf8716fa2e55b5d475cae3c7ded8d2ba2169ec66bc979bd2a9b3a58c15079802b3fd6bd0fe7f091b4aff9f259c SHA512 53bc8077e710cea8356abc6cef06ceb9503db9d4a06b59f5fad724b6aebd3c97665e1e9454b1564f7f2b483e10f7cfcb5230cc679777ffeee1ce3d54a981ff6f
+DIST vint-0.3.17.tar.gz 95358 BLAKE2B 102840bc2311148af5c20499c65417459d1abcdcaae0b95bd0bbb3e1569f98f0f0abb30ccae653aff844750efa340fc38a0f8905ee70b3aec8fdc5a8fcc0a6f6 SHA512 c3df61d47b4adf68ecfb8903ea0c030acbba3e72ce95514ef25823a5321181ebbf783c1a76613de9927acefb088edd890a0a776b40888cca62b2063e436820e6
diff --git a/dev-util/vint/vint-0.3.17.ebuild b/dev-util/vint/vint-0.3.17.ebuild
new file mode 100644
index 000000000000..e24dcd2fab20
--- /dev/null
+++ b/dev-util/vint/vint-0.3.17.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Lint tool for Vim script language"
+HOMEPAGE="https://github.com/Kuniwak/vint https://pypi.python.org/pypi/vim-vint/"
+SRC_URI="https://github.com/Kuniwak/vint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/ansicolor-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-pathlib[${PYTHON_USEDEP}]
+ virtual/python-typing[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/coverage-3.7.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-1.8.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' python2_7)
+ )
+"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ # Don't try to use an installed vint executable.
+ # See https://github.com/Kuniwak/vint/issues/22
+ sed -i -e "s|'vint'|'bin/vint'|" test/acceptance/test_cli{,_vital}.py || die
+}
+
+python_test() {
+ py.test -v || die "Test suite failed with ${EPYTHON}"
+}