summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Hernández Hernández <leohdz172@proton.me>2023-06-23 20:47:16 -0600
committerSam James <sam@gentoo.org>2023-06-24 03:58:37 +0100
commit6f8067983009650c7f15fa02649d48dd59122651 (patch)
treea59b7c7f886c5d83b0651c161118150b1064fce6 /dev-util
parentdev-libs/elfutils: replace `filter-flags -flto*` with `filter-lto` (diff)
downloadgentoo-6f8067983009650c7f15fa02649d48dd59122651.tar.gz
gentoo-6f8067983009650c7f15fa02649d48dd59122651.tar.bz2
gentoo-6f8067983009650c7f15fa02649d48dd59122651.zip
dev-util/cargo-ebuild: replace `filter-flags -flto*` with `filter-lto`
Signed-off-by: Leonardo Hernández Hernández <leohdz172@proton.me> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild4
-rw-r--r--dev-util/cargo-ebuild/cargo-ebuild-0.5.4.ebuild2
2 files changed, 3 insertions, 3 deletions
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
index 02b3b5bb3de2..c4e06eccd4aa 100644
--- a/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.5.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2017-2022 Gentoo Authors
+# Copyright 2017-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Auto-Generated by cargo-ebuild 0.5.1
@@ -170,7 +170,7 @@ RDEPEND="
QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/858332
+ filter-lto # https://bugs.gentoo.org/858332
export LIBGIT2_SYS_USE_PKG_CONFIG=1 LIBSSH2_SYS_USE_PKG_CONFIG=1 PKG_CONFIG_ALLOW_CROSS=1
cargo_src_configure
}
diff --git a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4.ebuild b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4.ebuild
index fe0ffcbbfc3c..2722dc5c7706 100644
--- a/dev-util/cargo-ebuild/cargo-ebuild-0.5.4.ebuild
+++ b/dev-util/cargo-ebuild/cargo-ebuild-0.5.4.ebuild
@@ -162,7 +162,7 @@ RDEPEND="
QA_FLAGS_IGNORED="usr/bin/cargo-ebuild"
src_configure() {
- filter-flags '-flto*' # https://bugs.gentoo.org/858332
+ filter-lto # https://bugs.gentoo.org/858332
export LIBGIT2_SYS_USE_PKG_CONFIG=1 LIBSSH2_SYS_USE_PKG_CONFIG=1 PKG_CONFIG_ALLOW_CROSS=1
cargo_src_configure
}