summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 21:57:20 -0500
committerSam James <sam@gentoo.org>2024-03-06 03:36:22 +0000
commit95bd4d2e42ab5a2cc58e1b683aa24273ad3078e5 (patch)
treedc8cff4e9153eb5a9fad65ee32fa65b529f041ff /dev-util
parentdev-util/sccache: make the zstd dependency effective (diff)
downloadgentoo-95bd4d2e42ab5a2cc58e1b683aa24273ad3078e5.tar.gz
gentoo-95bd4d2e42ab5a2cc58e1b683aa24273ad3078e5.tar.bz2
gentoo-95bd4d2e42ab5a2cc58e1b683aa24273ad3078e5.zip
dev-util/ply: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/858458 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ply/ply-2.3.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/ply/ply-2.3.0.ebuild b/dev-util/ply/ply-2.3.0.ebuild
index d6512d640f1a..ba9de28027fe 100644
--- a/dev-util/ply/ply-2.3.0.ebuild
+++ b/dev-util/ply/ply-2.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
HOMEPAGE="https://github.com/iovisor/ply"
@@ -34,6 +34,18 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858458
+ # https://github.com/iovisor/ply/issues/92
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
rm -f "${ED}/usr/share/doc/${P}/COPYING"