summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/bzr-xmloutput
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/bzr-xmloutput')
-rw-r--r--dev-vcs/bzr-xmloutput/Manifest1
-rw-r--r--dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r1.ebuild27
-rw-r--r--dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild28
-rw-r--r--dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch220
-rw-r--r--dev-vcs/bzr-xmloutput/metadata.xml8
5 files changed, 284 insertions, 0 deletions
diff --git a/dev-vcs/bzr-xmloutput/Manifest b/dev-vcs/bzr-xmloutput/Manifest
new file mode 100644
index 000000000000..01afeda0df0d
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/Manifest
@@ -0,0 +1 @@
+DIST bzr-xmloutput-0.8.8.tar.gz 49969 SHA256 73b9b2f6ce4d9910031df7fd153d56d14f833c20a106f099bee5a33463f73b36 SHA512 9eb87ba86dd45b7132eca69ef6e52726d7ee2d9211cc3052655e40f5cee2b99e160336c347ddce7ad912c0027e8b6a05ca542f70733d2e3493922cfa311b38ef WHIRLPOOL e07a08cd0738524207e7ab8d6c645b86d087391fb06d1e0ecf08cfbe78e6f6a1e730af41f4e2dea9e197e7c7f0de69cf6494ab1f906919febb86e06b490fe4e2
diff --git a/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r1.ebuild b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r1.ebuild
new file mode 100644
index 000000000000..ce4302f8d888
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="A Bazaar plugin that provides a option to generate XML output for
+builtin commands."
+HOMEPAGE="http://bazaar-vcs.org/XMLOutput"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/bzr"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}_remove-relative-imports.patch
+}
diff --git a/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild
new file mode 100644
index 000000000000..5fd210f25a21
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/bzr-xmloutput-0.8.8-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="A Bazaar plugin that provides a option to generate XML output forbuiltin commands."
+HOMEPAGE="http://bazaar-vcs.org/XMLOutput"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-vcs/bzr[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${P}_remove-relative-imports.patch )
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
diff --git a/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch b/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch
new file mode 100644
index 000000000000..b21eef05d2ad
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/files/bzr-xmloutput-0.8.8_remove-relative-imports.patch
@@ -0,0 +1,220 @@
+revno: 160 [merge]
+author: Jelmer Vernooij <jelmer@samba.org>
+committer: Guillermo Gonzalez <guillo.gonzo@gmail.com>
+branch nick: trunk
+timestamp: Mon 2011-12-19 18:45:35 -0300
+message:
+ Removes the use of relative imports and avoids using lazy_import in a few places we're it doesn't make a difference.
+
+Gentoo bug: https://bugs.gentoo.org/show_bug.cgi?id=418969
+Upstream bug: https://bugs.launchpad.net/bzr-xmloutput/+bug/955329
+Commit: http://bazaar.launchpad.net/~verterok/bzr-xmloutput/trunk/revision/160
+
+--- cmds.py 2011-03-09 23:19:41 +0000
++++ cmds.py 2011-12-12 15:11:38 +0000
+@@ -22,36 +22,39 @@
+
+ import info
+ import bzrlib
++from bzrlib.option import Option
++from bzrlib.commands import (
++ Command,
++ display_command,
++ )
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import sys
+ from bzrlib import (
+ builtins,
+ bzrdir,
+- commands,
+- option,
+ log,
+ workingtree,
+ errors
+ )
+
+-from bzrlib.option import Option, custom_help
+-from bzrlib.commands import display_command
+-import logxml
+-import service
++from bzrlib.plugins.xmloutput import (
++ logxml,
++ service,
++ )
+ import socket
+-from xml_errors import handle_error_xml
+ """)
+
++from bzrlib.plugins.xmloutput.xml_errors import handle_error_xml
+
+ version_info = info.bzr_plugin_version
+ plugin_name = info.bzr_plugin_name
+
+-null_option = option.Option('null',
+- help='Write an ascii NUL (\\0) as the final char.')
+-
+-
+-class cmd_xmlstatus(commands.Command):
++null_option = Option('null',
++ help='Write an ascii NUL (\\0) as the final char.')
++
++
++class cmd_xmlstatus(Command):
+ """Display status summary.
+
+ This reports on versioned and unknown files, reporting them
+@@ -118,7 +121,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlannotate(commands.Command):
++class cmd_xmlannotate(Command):
+ """Show the origin of each line in a file.
+
+ This prints out the given file with an annotation on the left side
+@@ -176,7 +179,7 @@
+ branch.unlock()
+
+
+-class cmd_xmlmissing(commands.Command):
++class cmd_xmlmissing(Command):
+ """Show unmerged/unpulled revisions between two branches.
+
+ OTHER_BRANCH may be local or remote.
+@@ -212,7 +215,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlinfo(commands.Command):
++class cmd_xmlinfo(Command):
+ """Show information about a working tree, branch or repository.
+
+ This command will show all known locations and formats associated to the
+@@ -247,7 +250,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlplugins(commands.Command):
++class cmd_xmlplugins(Command):
+ """List the installed plugins.
+
+ This command displays the list of installed plugins including
+@@ -284,7 +287,7 @@
+ self.outf.write('\n')
+
+
+-class cmd_xmlversion(commands.Command):
++class cmd_xmlversion(Command):
+ """Show version of bzr."""
+ hidden = True
+ encoding_type = 'replace'
+@@ -383,7 +386,7 @@
+ self.outf.write('\0')
+ self.outf.write('\n')
+
+-class cmd_start_xmlrpc(commands.Command):
++class cmd_start_xmlrpc(Command):
+ """Start the xmlrpc service."""
+
+ hidden = True
+@@ -413,7 +416,7 @@
+ self.server.shutdown()
+
+
+-class cmd_stop_xmlrpc(commands.Command):
++class cmd_stop_xmlrpc(Command):
+ """Stops a xmlrpc service."""
+
+ hidden = True
+
+--- infoxml.py 2009-07-28 03:43:56 +0000
++++ infoxml.py 2011-12-12 15:11:38 +0000
+@@ -27,6 +27,7 @@
+
+ __all__ = ['show_bzrdir_info_xml']
+
++from bzrlib import info
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import os, sys, time
+@@ -36,7 +37,6 @@
+ errors,
+ osutils,
+ urlutils,
+- info,
+ missing,
+ )
+ """)
+
+--- logxml.py 2010-12-15 18:27:12 +0000
++++ logxml.py 2011-12-12 15:11:38 +0000
+@@ -1,14 +1,12 @@
+ # -*- encoding: utf-8 -*-
+
+-import os
+-
++from bzrlib import log
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import bzrlib
+ from bzrlib import (
+ debug,
+ osutils,
+- log,
+ )
+ """)
+
+
+--- lsxml.py 2011-03-09 23:41:22 +0000
++++ lsxml.py 2011-12-12 15:11:38 +0000
+@@ -19,8 +19,6 @@
+ # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
+ #
+
+-import os
+-
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ from bzrlib import bzrdir, errors, osutils
+
+--- service.py 2010-02-23 23:38:02 +0000
++++ service.py 2011-12-12 15:11:38 +0000
+@@ -20,6 +20,8 @@
+ #
+ """ xmlrpc service module """
+
++import os
++
+ from bzrlib.lazy_import import lazy_import
+ lazy_import(globals(), """
+ import bzrlib
+@@ -30,14 +32,13 @@
+ osutils
+ )
+ import sys
+-import os
+ import codecs
+ import logging
+ import traceback
+ from cStringIO import StringIO
+ """)
+
+-from xml_errors import XMLError
++from bzrlib.plugins.xmloutput.xml_errors import XMLError
+ from xmlrpclib import Fault, Binary
+ from SimpleXMLRPCServer import SimpleXMLRPCServer
+
+
+--- statusxml.py 2010-12-15 18:27:12 +0000
++++ statusxml.py 2011-12-12 15:11:38 +0000
+@@ -33,7 +33,7 @@
+ trace,
+ )
+
+-import logxml
++from bzrlib.plugins.xmloutput import logxml
+ """)
+
+ from writer import _escape_cdata
+
diff --git a/dev-vcs/bzr-xmloutput/metadata.xml b/dev-vcs/bzr-xmloutput/metadata.xml
new file mode 100644
index 000000000000..db982428e047
--- /dev/null
+++ b/dev-vcs/bzr-xmloutput/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>bazaar</herd>
+ <upstream>
+ <remote-id type="launchpad">bzr-xmloutput</remote-id>
+ </upstream>
+</pkgmetadata>