summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-21 23:06:32 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-21 23:41:15 +0000
commit59bfe4ca4ad069f693cd93b749030a38a5f2d249 (patch)
tree92a396385b86fb115b71a95dd4080663f7fa0a32 /dev-vcs/git-machete
parentsys-auth/yubico-piv-tool: add 2.3.1 (diff)
downloadgentoo-59bfe4ca4ad069f693cd93b749030a38a5f2d249.tar.gz
gentoo-59bfe4ca4ad069f693cd93b749030a38a5f2d249.tar.bz2
gentoo-59bfe4ca4ad069f693cd93b749030a38a5f2d249.zip
dev-vcs/git-machete: add 3.15.2
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/git-machete')
-rw-r--r--dev-vcs/git-machete/Manifest1
-rw-r--r--dev-vcs/git-machete/git-machete-3.15.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-vcs/git-machete/Manifest b/dev-vcs/git-machete/Manifest
index 9aaa5d09c542..e4374a3e090f 100644
--- a/dev-vcs/git-machete/Manifest
+++ b/dev-vcs/git-machete/Manifest
@@ -1,2 +1,3 @@
DIST git-machete-3.13.0.gh.tar.gz 1388145 BLAKE2B e12c12ff5a34b7dee0ea14f4260154dc5c94a356a584c3bd00688777b4425a4c45fd39ece0c76751ff8b9b45c131ccd3d4ea25c3f14711ac91f75fa6a47e651e SHA512 85d719e9a983db9aea7bb7540c85aeb6ac5bfcbf94e4920683b37bae22714078f5e8b9a39d63fa397a03ddf139c52acd970310e499a26296fbdb1091672873f9
DIST git-machete-3.14.3.gh.tar.gz 1397234 BLAKE2B 827d3234260461d5cba6b192767e9923b79cc70afb0e7d0bd24e3f307559e3c0774499b34651dd6da7e52157c18becb69c15de9246b99bb35d47104787e6164e SHA512 a4e6015832b4fefa48b75dbd2f3aa50f53788c3a612beada971c0da9da722d49b48e891ddfa3f7d6c91ed4d461b16504ecab9f64b4da84d319b08bb06b1ee8c2
+DIST git-machete-3.15.2.gh.tar.gz 1399230 BLAKE2B f10ff0678b80e5a940a5746771addb1ef9f425faa49c64fd1c808c2f9236c8fb6973ddb662950582718a25b034eba9c3dba6a4008ae4702e5d662cd8796543f7 SHA512 64115f9bb2af7f0596d0327067adfe01ceb17e96325ae2ae31c377f1a86cd4f7eb6e5a5940efb46a9e9d6805ae0b61a8d1d52e0ed7e4f65250783c290d8989cc
diff --git a/dev-vcs/git-machete/git-machete-3.15.2.ebuild b/dev-vcs/git-machete/git-machete-3.15.2.ebuild
new file mode 100644
index 000000000000..9964c2ef2ad2
--- /dev/null
+++ b/dev-vcs/git-machete/git-machete-3.15.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Probably the sharpest git repo organizer & rebase/merge workflow automation tool"
+HOMEPAGE="https://github.com/VirtusLab/git-machete https://pypi.org/project/git-machete/"
+# No tests in PyPI tarballs
+SRC_URI="https://github.com/VirtusLab/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="dev-vcs/git"
+BDEPEND="test? (
+ >=dev-python/pytest-mock-3.8.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-2.5.0[${PYTHON_USEDEP}]
+)"
+
+DOCS=( CONTRIBUTING.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ newbashcomp completion/${PN}.completion.bash ${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completion/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ newins completion/${PN}.completion.zsh _${PN}
+}