summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-01-23 11:22:32 +0000
committerYixun Lan <dlan@gentoo.org>2024-01-23 11:25:18 +0000
commit388dedf047c2f00822f1358a994e0f53312d8f67 (patch)
tree4e6393ccf1607046c9949c23d649e469481c0c6b /dev-vcs/git-pw
parentsys-power/thermald: add 2.5.5 (diff)
downloadgentoo-388dedf047c2f00822f1358a994e0f53312d8f67.tar.gz
gentoo-388dedf047c2f00822f1358a994e0f53312d8f67.tar.bz2
gentoo-388dedf047c2f00822f1358a994e0f53312d8f67.zip
dev-vcs/git-pw: add 2.6.0
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-vcs/git-pw')
-rw-r--r--dev-vcs/git-pw/Manifest1
-rw-r--r--dev-vcs/git-pw/git-pw-2.6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-vcs/git-pw/Manifest b/dev-vcs/git-pw/Manifest
index cd539f9d7ac9..f5d140e0bb1c 100644
--- a/dev-vcs/git-pw/Manifest
+++ b/dev-vcs/git-pw/Manifest
@@ -1,2 +1,3 @@
DIST git-pw-2.4.0.tar.gz 34874 BLAKE2B cc44b3e8660e8ede70a32b2e7d79dc000c050a7359b9d092df535bb0d79f79dc6c95f2b8563e7f750cc74618530db376a1dee08802bc1f2f4b7239b1f4fe57c3 SHA512 5a2b22d33903c779d319a40afbce8f7137272d5fcd4ebd62901b59468333523aea3c276b56cc7227d4aa2b53c30664ac07858bab2f80ef99a55a28af0feecefb
DIST git-pw-2.5.0.tar.gz 35380 BLAKE2B 18b8e7eab4140b2e1010fb346e9dd3f39cf0c0b8d750c596590ecdb2693e8721834917680664ae166092addb6ea9d3bd67dc3060db7773ca488a8f714cfa248e SHA512 46d44187b4d5dd87b484461fa00fa805c475f32f40d2cb05fa3cdbeebd83f04636082af23e5cba7b07ecb89ad4ff81470da9b8fef3dccd50fbdcca48483c82e8
+DIST git-pw-2.6.0.tar.gz 35628 BLAKE2B 6f6b5200776eb88c9ab4fcb5149b2e95f90a5d8dcd7bb18b07f326454e8a397266976a8f7f6b635857ebf3da876f9a0c75cd195d731406ef89ef45fe21672ef1 SHA512 b99efa89a5efcf34bd53b0fd691bb9c86f7585f352faab99a795f0902801c95310a7ea1414f8eb0bfac73f8d6af9b4cc7897d7d33cbeb4f3a5faedd35e62af4f
diff --git a/dev-vcs/git-pw/git-pw-2.6.0.ebuild b/dev-vcs/git-pw/git-pw-2.6.0.ebuild
new file mode 100644
index 000000000000..ccb909f73e2f
--- /dev/null
+++ b/dev-vcs/git-pw/git-pw-2.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=pbr
+
+inherit distutils-r1
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/getpatchwork/git-pw.git"
+else
+ SRC_URI="https://github.com/getpatchwork/git-pw/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool for integrating Git with Patchwork"
+HOMEPAGE="https://github.com/getpatchwork/git-pw"
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/arrow-0.10[${PYTHON_USEDEP}]
+ >=dev-python/click-6.0[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/mock-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.5[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ export PBR_VERSION=${PV}
+ distutils-r1_src_compile
+}
+distutils_enable_tests pytest