summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-04-20 22:06:43 +0300
committerSam James <sam@gentoo.org>2023-04-26 05:02:49 +0100
commit3837924b5d576ee7e77361a43ebef527ca2ee7c3 (patch)
treeffa2b37bec03aa24afd1231a46855416a6d5376e /dev-vcs/tortoisehg
parentsys-fs/cryfs: enable py3.11 (diff)
downloadgentoo-3837924b5d576ee7e77361a43ebef527ca2ee7c3.tar.gz
gentoo-3837924b5d576ee7e77361a43ebef527ca2ee7c3.tar.bz2
gentoo-3837924b5d576ee7e77361a43ebef527ca2ee7c3.zip
dev-vcs/tortoisehg: 6.4.2 version bump
Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/30670 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-6.4.2.ebuild81
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild6
3 files changed, 85 insertions, 3 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index fe0ab9c4af6c..963ae75c6218 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1,2 +1,3 @@
DIST tortoisehg-6.2.3.tar.gz 8878641 BLAKE2B ede267f48c7b58db1fcdf16a11fb343e4fcf21193a43f6d6114ef6f930946beea458acc52780deaa889d429989c7b8b25045a9ed340297c0d1ee7e5e5e998d2a SHA512 8c7e62822bdbdcae7a371b910e3e549864019b3a74a090e59d0f26291525ebda078de3f41d8442b457e14727ec94143290d0f3fac9f49cbe842d1de298ae2edd
DIST tortoisehg-6.3.2.tar.gz 8885325 BLAKE2B bb9a7043f7d2e44b32e20b6dd88372927977a6fd94b662a8a56d26776c72268e0953de3edc93b2f7b9efc580286632f500f5181a5ef7bf3edd3fb5ba5ec64761 SHA512 b711f9d347b2f00978b42b258713d365188c4de100668a09fea4b6f80bb8083a7980a462b8fb4705d31f9da310dbdeb2d9891e93f6e3f6f2833e4c7ccfa4d800
+DIST tortoisehg-6.4.2.tar.gz 8854453 BLAKE2B 04c57de8ea745cdcd33fe8a65b95f76937b59f01486eec6f305eed52dceaed898d55b95769de8a4f41606a3dda6d81e44d3eb1690ee6dde7ab21526b2a46032d SHA512 efe23a991130423aa374e7dd5fe051fabcc6d48c3596a355c7d21dfa35de062411cf2edc3efe4800146c6b3ab4dbd064da54a4f27988297cfd6dc1f69ab14e22
diff --git a/dev-vcs/tortoisehg/tortoisehg-6.4.2.ebuild b/dev-vcs/tortoisehg/tortoisehg-6.4.2.ebuild
new file mode 100644
index 000000000000..7222b381f779
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-6.4.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit desktop distutils-r1 optfeature xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
+ <dev-vcs/mercurial-6.5[${PYTHON_USEDEP}]"
+ S="${WORKDIR}/thg-${PV}"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.11.6[qt5(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+
+ sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} tests/run-tests.py -m 'not largefiles' --disable-pytest-warnings --doctest-modules tests || die "Tests failed with ${EPYTHON}"
+ ${EPYTHON} tests/run-tests.py -m largefiles --disable-pytest-warnings tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+
+ optfeature "the core git extension support" dev-python/pygit2
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index b14e5b79045a..7222b381f779 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -11,15 +11,15 @@ inherit desktop distutils-r1 optfeature xdg-utils
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~arm64 ~x86"
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
- HG_DEPEND=">=dev-vcs/mercurial-5.9[${PYTHON_USEDEP}]
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
- <dev-vcs/mercurial-6.4[${PYTHON_USEDEP}]"
+ <dev-vcs/mercurial-6.5[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial
EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
EHG_REVISION="stable"
- HG_DEPEND=">=dev-vcs/mercurial-5.9[${PYTHON_USEDEP}]"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]"
fi
DESCRIPTION="Set of graphical tools for Mercurial"