summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2022-05-13 22:54:26 +1000
committerJoonas Niilola <juippis@gentoo.org>2022-05-18 18:14:01 +0300
commit5e53f47a7048713ae44b9bdb895f503238f8f8a4 (patch)
tree9008313804993ebfa1cb5dbd99e5152303cddf96 /dev-vcs
parentdev-vcs/git-lfs: add 3.1.4 (diff)
downloadgentoo-5e53f47a7048713ae44b9bdb895f503238f8f8a4.tar.gz
gentoo-5e53f47a7048713ae44b9bdb895f503238f8f8a4.tar.bz2
gentoo-5e53f47a7048713ae44b9bdb895f503238f8f8a4.zip
dev-vcs/git-lfs: drop 2.11.0-r1, 2.13.3-r1
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/25465 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/Manifest2
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.11.0-r1.ebuild62
-rw-r--r--dev-vcs/git-lfs/git-lfs-2.13.3-r1.ebuild70
3 files changed, 0 insertions, 134 deletions
diff --git a/dev-vcs/git-lfs/Manifest b/dev-vcs/git-lfs/Manifest
index eeca199a127b..f705d371bd58 100644
--- a/dev-vcs/git-lfs/Manifest
+++ b/dev-vcs/git-lfs/Manifest
@@ -1,4 +1,2 @@
-DIST git-lfs-2.11.0.tar.gz 2839623 BLAKE2B e9d0e8ea37f19617a4f727abdc93c3c937052ad98b6ac40de27ced6b250789701797d04f1bf795b259e83155e5d8a1ca122dbf8b40503c2c41d6d891a3ecf096 SHA512 2117b425864a36f773c14d34c78999636d836646184cf8d89045ef6de90cbded873d4de4613ecfafb0fa2ea8ae068e11f5ae22eed6af01715b5fac9be70f033b
-DIST git-lfs-2.13.3.tar.gz 2901796 BLAKE2B 84bbce719e83229bbb7116f5c337e0748a2be223b260e03653dab23f6c8d20087a09695d6ef7abf45e128bfd79c5eb994cb14fb906330675174830603a2e3ba2 SHA512 2c9e10e4f2fdb5d6bae8994db5879f50596109f3057e7369a9edca3c13c3f4d77e268e3903a0abca60cf8e342ff54bc4920c01a530f8eb400e3a0cc11a171f74
DIST git-lfs-3.1.2.tar.gz 3254358 BLAKE2B 77df9aef438c2d839b6a3690c6f34191b993180be7b3cbccedbe2d439cd8d77676f91a864598af40ebfe4d9d021bbc179bb6bcbb3635ca0a7ed78eecd2da0246 SHA512 de2b56146b929adf7f6ff1989f07d4aca59bde218a51273c0d443a4cace0ccfcf9d4d72c2458c53f95fe06f092baaf6ccbde304e9ca20691ccb9e7aa56f49ebb
DIST git-lfs-3.1.4.tar.gz 3254376 BLAKE2B 3eeb32b6a9b5c40f53b9c32a557911edf2216243108250aae407280b2a26293ce4cb981f1bb2863dcaf5553976ba34fa42ec4dc8a1a76cd0fd5946fd482b2f99 SHA512 ff62e19532ec09d71e241ffb9b6a0ed91a76cbe1fe32a88a6e3679e15cf97b09bcfdb5fc1aa0c1a9984bc888c88be87940bd7044d68102eadf93cb68dc5e9c1c
diff --git a/dev-vcs/git-lfs/git-lfs-2.11.0-r1.ebuild b/dev-vcs/git-lfs/git-lfs-2.11.0-r1.ebuild
deleted file mode 100644
index 5db47f6cb90f..000000000000
--- a/dev-vcs/git-lfs/git-lfs-2.11.0-r1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-EGO_PN=github.com/git-lfs/git-lfs
-inherit go-module
-
-DESCRIPTION="Command line extension and specification for managing large files with git"
-HOMEPAGE="https://git-lfs.github.com/"
-
-if [[ "${PV}" = 9999* ]]; then
- EGIT_REPO_URI="https://${EGO_PN}"
- inherit git-r3
-else
- SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
-SLOT="0"
-IUSE="doc test"
-
-BDEPEND="doc? ( || ( app-text/ronn-ng app-text/ronn ) )"
-RDEPEND="dev-vcs/git"
-
-RESTRICT+=" !test? ( test )"
-
-src_compile() {
- set -- go build \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor -v -work -x \
- -o git-lfs git-lfs.go
- echo "$@"
- "$@" || die
-
- if use doc; then
- ronn docs/man/*.ronn || die "man building failed"
- fi
-}
-
-src_install() {
- dobin git-lfs
- dodoc {CHANGELOG,CODE-OF-CONDUCT,CONTRIBUTING,README}.md
- use doc && doman docs/man/*.1
-}
-
-src_test() {
- set -- go test \
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}" \
- -mod vendor \
- ./...
- echo "$@"
- "$@" || die
-}
-
-pkg_postinst () {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog ""
- elog "Run \'git lfs install\' once for each user account manually."
- elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
- fi
-}
diff --git a/dev-vcs/git-lfs/git-lfs-2.13.3-r1.ebuild b/dev-vcs/git-lfs/git-lfs-2.13.3-r1.ebuild
deleted file mode 100644
index 2cf565a6aba2..000000000000
--- a/dev-vcs/git-lfs/git-lfs-2.13.3-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-EGO_PN=github.com/git-lfs/git-lfs
-inherit go-module
-
-DESCRIPTION="Command line extension and specification for managing large files with git"
-HOMEPAGE="https://git-lfs.github.com/"
-
-if [[ "${PV}" = 9999* ]]; then
- EGIT_REPO_URI="https://${EGO_PN}"
- inherit git-r3
-else
- SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="Apache-2.0 BSD BSD-2 BSD-4 ISC MIT"
-SLOT="0"
-IUSE="doc test"
-
-BDEPEND="doc? ( || ( app-text/ronn-ng app-text/ronn ) )"
-RDEPEND="dev-vcs/git"
-
-RESTRICT+=" !test? ( test )"
-
-DOCS=(
- CHANGELOG.md
- CODE-OF-CONDUCT.md
- CONTRIBUTING.md
- README.md
- SECURITY.md
-)
-
-src_compile() {
- # Flags -w, -s: Omit debugging information to reduce binary size,
- # see https://golang.org/cmd/link/.
- local mygobuildargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT} -s -w"
- -mod vendor -v -work -x
- )
- go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
-
- if use doc; then
- ronn docs/man/*.ronn || die "man building failed"
- fi
-}
-
-src_install() {
- dobin git-lfs
- einstalldocs
- use doc && doman docs/man/*.1
-}
-
-src_test() {
- local mygotestargs=(
- -ldflags="-X ${EGO_PN}/config.GitCommit=${GIT_COMMIT}"
- -mod vendor
- )
- go test "${mygotestargs[@]}" ./... || die
-}
-
-pkg_postinst () {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- elog ""
- elog "Run \'git lfs install\' once for each user account manually."
- elog "For more details see https://bugs.gentoo.org/show_bug.cgi?id=733372."
- fi
-}